Turn signal issue-2010 Kingpin - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old 11-18-2012, 03:19 PM Thread Starter
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Turn signal issue-2010 Kingpin

Today on a ride, I noticed my right front turn signal was flashing fast, rear right was doing nothing. Stopped at the auto parts store to pick up a pair of new ones. New bulb did the same thing. Swapped originals right to left, same thing. Where do I start looking for the problem?

2010 Kingpin
guitfit is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-19-2012, 03:52 AM
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,093
right rear socket is the problem make sure you are getting black wire to ground continuity, bu/r wire is the voltage from the ECM. It is protected by a diode. So any back feed will pop the diode. If you have not changed your lights to LED you should be OK. dielectric grease in the socket to keep corrosion out.

2012 Fireball Jackpot
gibson is offline  
post #3 of 7 (permalink) Old 11-19-2012, 05:24 AM Thread Starter
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Is the diode located in the socket? And if so, is it replaceable? Can I find one at Radio Shack? Value?

2010 Kingpin
guitfit is offline  
post #4 of 7 (permalink) Old 11-19-2012, 07:24 AM
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,093
did you check to see if you was getting voltage to the bulb? harness under the seat to the fender. If the front bulb has power the diode is ok so it has to be the wire harness connection or the socket.

2012 Fireball Jackpot
gibson is offline  
post #5 of 7 (permalink) Old 11-20-2012, 02:27 AM Thread Starter
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
I checked, no power to the left signal. I guess it's time to pull the fender and see what's going on under there. Thanks. BTW, have a great Thanksgiving!

2010 Kingpin
guitfit is offline  
post #6 of 7 (permalink) Old 11-20-2012, 04:14 AM
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,093
Attachment 8859here is a few from the book that shows the connectionAttachment 8860

2012 Fireball Jackpot

Last edited by gibson; 08-02-2013 at 04:17 AM.
gibson is offline  
post #7 of 7 (permalink) Old 11-22-2012, 10:43 AM Thread Starter
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Thanks for your help gibson. I'm glad I didn't need those schematics. When I took the fender off and looked at the wiring harness, I noticed both connectors for the left turn signal had come apart. I just plugged them back in, zip tied the rest of the wiring so it would stay behind the plastic shroud in the fender, and put it back together. It works! Have a happy Thanksgiving!

2010 Kingpin
guitfit is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome