Engine Light On after PCV install, dies??? - Victory Forums - Victory Motorcycle Forum
 19Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 27 (permalink) Old 04-15-2017, 11:19 PM Thread Starter
Member
 
VicVisionBulldog's Avatar
 
Join Date: Apr 2017
Location: Houston, Tx
Posts: 95
Garage
Question Engine Light On after PCV install, dies???

I just installed a PCV on my 13 Vision. Everything seemed to go well until start up. I started it with a canned map and it fired right up. Shortly after firing up the check engine light comes on and stays. Then I found that if I do anything other than a turtle slow increase in the throttle the motor dies. I next tried the Zero map to see if that fixed the issue but the bike acts the same.

Because of this I have not taken it for a ride.

Ive checked the plugs and they all seem tight and I believe they are correct and have run out of things to try from searching here and there.

Any ideas?

13 Vision Tour - PCV, Top Filter, Stage 1 Pipes, soon to add wheel, Metz 888s

08 Vision Street Premium - VFC, Top Filter, Stage 1 Level 2 Pipes, E4s

Past Vic - 07 KP Tour - Stage 1, S&S Intake

Last edited by VicVisionBulldog; 04-15-2017 at 11:21 PM.
VicVisionBulldog is offline  
Sponsored Links
Advertisement
 
post #2 of 27 (permalink) Old 04-15-2017, 11:26 PM
Senior Member
 
Join Date: Mar 2011
Location: Buckeye, Az.
Posts: 1,128
New

New or used PCV? I think I would disable it and hook the wiring back up stock to see if it runs again. If it does you know the problem is with the PCV or the programming. Just my thoughts on it.

Goodyear, Arizona(USA) 2011 Victory Cross Roads, Black police bag guards, black engine guards, black Vegas 8 Ball handle bars, Triumph Tiger mirrors, Triumph hand grips, set speedo/tach back 5" , adjustable timing wheel, Lloyzz Fuel Programmer III & air filter. Modified exhaust, made stock into 2 into 1. Moved front fender forward. MRA windshield.
Speedblue is offline  
post #3 of 27 (permalink) Old 04-15-2017, 11:29 PM Thread Starter
Member
 
VicVisionBulldog's Avatar
 
Join Date: Apr 2017
Location: Houston, Tx
Posts: 95
Garage
Quote:
Originally Posted by Speedblue View Post
New or used PCV? I think I would disable it and hook the wiring back up stock to see if it runs again. If it does you know the problem is with the PCV or the programming. Just my thoughts on it.
Used. I go it and an Auto Tuner but I didn't have time to install the AT today. I was going to run a canned map until I get the AT on and let it do its thing.

13 Vision Tour - PCV, Top Filter, Stage 1 Pipes, soon to add wheel, Metz 888s

08 Vision Street Premium - VFC, Top Filter, Stage 1 Level 2 Pipes, E4s

Past Vic - 07 KP Tour - Stage 1, S&S Intake
VicVisionBulldog is offline  
 
post #4 of 27 (permalink) Old 04-16-2017, 12:14 AM Thread Starter
Member
 
VicVisionBulldog's Avatar
 
Join Date: Apr 2017
Location: Houston, Tx
Posts: 95
Garage
Updated the firmware. Tried both maps again. Same results.



The instructions kinda suck for this.


I unplugged the O2 sensor. Is that what I was supposed to do?

I'm seeing there is an O2 optimizer. Do I need something like that?

13 Vision Tour - PCV, Top Filter, Stage 1 Pipes, soon to add wheel, Metz 888s

08 Vision Street Premium - VFC, Top Filter, Stage 1 Level 2 Pipes, E4s

Past Vic - 07 KP Tour - Stage 1, S&S Intake

Last edited by VicVisionBulldog; 04-16-2017 at 12:17 AM.
VicVisionBulldog is offline  
post #5 of 27 (permalink) Old 04-16-2017, 12:17 AM
Member
 
cruzie27's Avatar
 
Join Date: Sep 2015
Location: Coal country, PA.
Posts: 94
Garage
How do you have the PCV grounded?
PaiN likes this.

2016 Victory Gunner
cruzie27 is offline  
post #6 of 27 (permalink) Old 04-16-2017, 12:20 AM Thread Starter
Member
 
VicVisionBulldog's Avatar
 
Join Date: Apr 2017
Location: Houston, Tx
Posts: 95
Garage
Quote:
Originally Posted by cruzie27 View Post
How do you have the PCV grounded?
The bolt just to the right of the center dash. There is another ground wire there too.

13 Vision Tour - PCV, Top Filter, Stage 1 Pipes, soon to add wheel, Metz 888s

08 Vision Street Premium - VFC, Top Filter, Stage 1 Level 2 Pipes, E4s

Past Vic - 07 KP Tour - Stage 1, S&S Intake
VicVisionBulldog is offline  
post #7 of 27 (permalink) Old 04-16-2017, 12:33 AM
Member
 
cruzie27's Avatar
 
Join Date: Sep 2015
Location: Coal country, PA.
Posts: 94
Garage
There was something about the ground with the core frame bikes,... for the life of me I can't remember exactly what it was. That sounds like a long way from the battery or engine ground though.

Are all of the connectors ok? Any bent or damaged pins in the connectors? When it dies is it silimar to the way it dies when you blip the throttle or is it more of a stuttering slow kind of shutoff?

2016 Victory Gunner
cruzie27 is offline  
post #8 of 27 (permalink) Old 04-16-2017, 12:48 AM Thread Starter
Member
 
VicVisionBulldog's Avatar
 
Join Date: Apr 2017
Location: Houston, Tx
Posts: 95
Garage
Quote:
Originally Posted by cruzie27 View Post
There was something about the ground with the core frame bikes,... for the life of me I can't remember exactly what it was. That sounds like a long way from the battery or engine ground though.

Are all of the connectors ok? Any bent or damaged pins in the connectors? When it dies is it silimar to the way it dies when you blip the throttle or is it more of a stuttering slow kind of shutoff?
Am the plugs and pins were good in the install. Connected easily.

When it dies its a hard one. No stutter.

If I slowly rev it the motor sounds good, just as it did before the PVC.

13 Vision Tour - PCV, Top Filter, Stage 1 Pipes, soon to add wheel, Metz 888s

08 Vision Street Premium - VFC, Top Filter, Stage 1 Level 2 Pipes, E4s

Past Vic - 07 KP Tour - Stage 1, S&S Intake
VicVisionBulldog is offline  
post #9 of 27 (permalink) Old 04-16-2017, 05:08 AM
Senior Member
 
PaiN's Avatar
 
Join Date: May 2014
Location: CT, USA
Posts: 3,006
Garage
@cruzie27 is barking up all the right trees. All I can add is since you bought it used, do you know for sure it was working for the previous owner? Also, PC-Vs have the ability to switch between two different maps. This has to be done with a physical switch. I'm not 100% certain but I believe when an Auto-Tune is connected one of these map slots is used for it. Maybe you might have to switch to the standard maps slot. The last thing I can add is if all else is correctly connected, grounded and you're on the right map slot....the symptoms seem like a fault on the TPS signal to the PC-V.
cruzie27 and VicVisionBulldog like this.

The Destroyer Approaches

"Living life is a great idea, but riding a motorcycle actually gives you a tool to do it..." -me
2013 Sunset Red Cross Country
Vic Tri-Oval Mufflers, Lloydz AF, ATS+2, PC-V tune by Dyno Solutions
Drag Specialties low-profile Touring Seat, Klock Werks Klip Hanger bars
Kuryakyn ISO grips/bar ends and SwingWing rear boards
Victory black LED headlight and Touring Pack.
PaiN is offline  
post #10 of 27 (permalink) Old 04-16-2017, 07:55 AM
Lifetime Premium
 
depot picker's Avatar
 
Join Date: Oct 2011
Location: NW GA
Posts: 1,774
Is it possible you have the cables to the injectors or o2 sensors reversed?
broggyr likes this.

IBA Member
2012 XCT "Marguerite" 111/107
PCV, timing wheel, DR cams and tuned
Lloydz filter, drilled, Ness modular apes.
depot picker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome