No oil pressure [Archive] - Victory Forums - Victory Motorcycle Forum

: No oil pressure


mistacat
03-22-2010, 04:19 PM
No oil pressure on 2006 Jackpot. oil pressure switch ok. levels ok, Have fed 50 psi remote oil source into pressure switch hole, ( to prime pump and check pressure leakdown, leakdown seems good ) no output from oil pump.
Have there been instances of pump drive chain failure or drive shear ?
Any information or suggestions welcomed. looks a big job to take the engine out and strip it.!!

mistacat
03-25-2010, 03:14 PM
No answers so pulled and stripped motor, Oil pump sprocket in half with teeth missing and drive chain broken.
Bike has done 7000 miles.
I would not fit a drive chain and sprocket this size on a childs bicycle!
Might be best to upgrade to a VN1600.

kevinx
03-25-2010, 07:11 PM
This make a total of TWO failures I have heard of with pump/chain. In the 6 years I have been involved with Vics. The pump is a rotary unit that has constant pressure. The nature of that type of pump is that since there is no pulsing there. It does not require a overly large drive mechanism.

All that said it totally SUCKS that you had it happen to you.

stevie3x
03-25-2010, 11:21 PM
yes i agree thats a pisser, concern i have [ coming from a v. w. background ] whenever we had a like situation we throughly cleaned out the engine case , cleaned and inspected all parts for debris contamination, and chucked the oil cooler,

whats your take , kevin ?


steve

mistacat
03-26-2010, 02:49 AM
Hi Again,
Stevie the crankcases were spotless apart from the chain/ sprocket debris. relief valves & pump Good. As I remember stock VW oil problems were the lack of a proper filter just a strainer.
I would not dispute that these gerotor double pumps are not smooth in operation.
In fact with 20-40 oil at 36 deg f and relief valves at 85 psi and 105 psi I would agree that they are very smooth. But take a lot of force to turn them. Ok till the cold engine coughs or sneezes just imagine the load on the chain and even more the load on that little plate sprocket 2.7mm thick and a floating fit driving on 2 tiny flats no wonder it split in half !!!.
Anyway have ordered the parts I see that there is a new part number for the sprocket ???
While the engine is out and waiting 2 weeks for the parts to arrive it will give me plenty of time to weld the crack in the rear cylinder head next to the frame mount that has been weeping oil for the past 9 months.

kevinx
03-26-2010, 07:05 AM
Damn man. Broken gear, AND a weeping head!! Has this thing been in a wreck??

mistacat
03-26-2010, 12:43 PM
Hi Kevinx,
Bike has never been dropped and only done 7k miles. In fact it is a very nice looking bike but as they say beauty is only skin deep.
By contrast I have a 94 BMW1000cc airhead boxer twin, Ugliest looking motorcycle you ever saw but superbly engineered.