Turn signal issue-2010 Kingpin - Victory Forums - Victory Motorcycle Forum
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games
Go Back   Victory Forums - Victory Motorcycle Forum > Victory Motorcycles > Victory Tech and Performance Section

Reply
 
Thread Tools Search this Thread Display Modes
Old 11-18-2012, 04:19 PM   #1
guitfit
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Default Turn signal issue-2010 Kingpin

Today on a ride, I noticed my right front turn signal was flashing fast, rear right was doing nothing. Stopped at the auto parts store to pick up a pair of new ones. New bulb did the same thing. Swapped originals right to left, same thing. Where do I start looking for the problem?
__________________
2010 Kingpin
guitfit is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-19-2012, 04:52 AM   #2
gibson
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,017
Default

right rear socket is the problem make sure you are getting black wire to ground continuity, bu/r wire is the voltage from the ECM. It is protected by a diode. So any back feed will pop the diode. If you have not changed your lights to LED you should be OK. dielectric grease in the socket to keep corrosion out.
gibson is offline   Reply With Quote
Old 11-19-2012, 06:24 AM   #3
guitfit
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Default

Is the diode located in the socket? And if so, is it replaceable? Can I find one at Radio Shack? Value?
__________________
2010 Kingpin
guitfit is offline   Reply With Quote
Old 11-19-2012, 08:24 AM   #4
gibson
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,017
Default

did you check to see if you was getting voltage to the bulb? harness under the seat to the fender. If the front bulb has power the diode is ok so it has to be the wire harness connection or the socket.
gibson is offline   Reply With Quote
Old 11-20-2012, 03:27 AM   #5
guitfit
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Default

I checked, no power to the left signal. I guess it's time to pull the fender and see what's going on under there. Thanks. BTW, have a great Thanksgiving!
__________________
2010 Kingpin
guitfit is offline   Reply With Quote
Old 11-20-2012, 05:14 AM   #6
gibson
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,017
Default

Attachment 8859here is a few from the book that shows the connectionAttachment 8860

Last edited by gibson; 08-02-2013 at 05:17 AM.
gibson is offline   Reply With Quote
Old 11-22-2012, 11:43 AM   #7
guitfit
Member
 
Join Date: May 2012
Location: Bradenton, Fl
Posts: 52
Default

Thanks for your help gibson. I'm glad I didn't need those schematics. When I took the fender off and looked at the wiring harness, I noticed both connectors for the left turn signal had come apart. I just plugged them back in, zip tied the rest of the wiring so it would stay behind the plastic shroud in the fender, and put it back together. It works! Have a happy Thanksgiving!
__________________
2010 Kingpin
guitfit is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:10 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum