No oil pressure - Victory Forums - Victory Motorcycle Forum
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games
Go Back   Victory Forums - Victory Motorcycle Forum > Victory Motorcycles > Victory Jackpot Forum

Reply
 
Thread Tools Search this Thread Display Modes
Old 03-22-2010, 03:19 PM   #1
mistacat
New Member
 
Join Date: Mar 2010
Posts: 4
Default No oil pressure

No oil pressure on 2006 Jackpot. oil pressure switch ok. levels ok, Have fed 50 psi remote oil source into pressure switch hole, ( to prime pump and check pressure leakdown, leakdown seems good ) no output from oil pump.
Have there been instances of pump drive chain failure or drive shear ?
Any information or suggestions welcomed. looks a big job to take the engine out and strip it.!!
mistacat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-25-2010, 02:14 PM   #2
mistacat
New Member
 
Join Date: Mar 2010
Posts: 4
Default Oil pressure update

No answers so pulled and stripped motor, Oil pump sprocket in half with teeth missing and drive chain broken.
Bike has done 7000 miles.
I would not fit a drive chain and sprocket this size on a childs bicycle!
Might be best to upgrade to a VN1600.
mistacat is offline   Reply With Quote
Old 03-25-2010, 06:11 PM   #3
kevinx
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At home, or work
Posts: 2,019
Default

This make a total of TWO failures I have heard of with pump/chain. In the 6 years I have been involved with Vics. The pump is a rotary unit that has constant pressure. The nature of that type of pump is that since there is no pulsing there. It does not require a overly large drive mechanism.

All that said it totally SUCKS that you had it happen to you.
kevinx is offline   Reply With Quote
Old 03-25-2010, 10:21 PM   #4
stevie3x
Senior Member
 
Join Date: Nov 2009
Posts: 243
Default

yes i agree thats a pisser, concern i have [ coming from a v. w. background ] whenever we had a like situation we throughly cleaned out the engine case , cleaned and inspected all parts for debris contamination, and chucked the oil cooler,

whats your take , kevin ?


steve
stevie3x is offline   Reply With Quote
Old 03-26-2010, 01:49 AM   #5
mistacat
New Member
 
Join Date: Mar 2010
Posts: 4
Default Oil pressure update

Hi Again,
Stevie the crankcases were spotless apart from the chain/ sprocket debris. relief valves & pump Good. As I remember stock VW oil problems were the lack of a proper filter just a strainer.
I would not dispute that these gerotor double pumps are not smooth in operation.
In fact with 20-40 oil at 36 deg f and relief valves at 85 psi and 105 psi I would agree that they are very smooth. But take a lot of force to turn them. Ok till the cold engine coughs or sneezes just imagine the load on the chain and even more the load on that little plate sprocket 2.7mm thick and a floating fit driving on 2 tiny flats no wonder it split in half !!!.
Anyway have ordered the parts I see that there is a new part number for the sprocket ???
While the engine is out and waiting 2 weeks for the parts to arrive it will give me plenty of time to weld the crack in the rear cylinder head next to the frame mount that has been weeping oil for the past 9 months.
mistacat is offline   Reply With Quote
Old 03-26-2010, 06:05 AM   #6
kevinx
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At home, or work
Posts: 2,019
Default

Damn man. Broken gear, AND a weeping head!! Has this thing been in a wreck??
kevinx is offline   Reply With Quote
Old 03-26-2010, 11:43 AM   #7
mistacat
New Member
 
Join Date: Mar 2010
Posts: 4
Default Oil pressure update

Hi Kevinx,
Bike has never been dropped and only done 7k miles. In fact it is a very nice looking bike but as they say beauty is only skin deep.
By contrast I have a 94 BMW1000cc airhead boxer twin, Ugliest looking motorcycle you ever saw but superbly engineered.
mistacat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 04:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum