01' V92 Speedometer Prob - Victory Forums - Victory Motorcycle Forum
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games
Go Back   Victory Forums - Victory Motorcycle Forum > Victory Motorcycles > Victory Tech and Performance Section

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-22-2010, 03:30 PM   #1
Dilligas
New Member
 
Join Date: Jun 2010
Posts: 2
Question 01' V92 Speedometer Prob

The speedometer has quit working all together. However, all the digital readouts are still working in the digital window (fuel, alt, mileage, etc). I'm sure its not cable driven, so there must be a sensor somewhere. Someone point me to it?
Dilligas is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-23-2010, 07:14 PM   #2
Shanesr
Junior Member
 
Join Date: May 2010
Posts: 16
Default My 2001 did the same thing

My bike did the same thing I could turn the key off and back on and it would start working, I cleaned the key switch and the sensor that is down at the drive sprocket for the belt drive with contact cleaner,
I also unpluged the sensor and cleaned the plug, it has been working since I did this, hope it works for you,
Shane
Shanesr is offline   Reply With Quote
Old 06-24-2010, 09:19 AM   #3
diamondrmp
The Diamond
 
diamondrmp's Avatar
 
Join Date: Aug 2009
Location: N. California via Los Angeles, CA
Posts: 4,003
Garage
Default

Cleaning is great and don't forget the electrical grease!!!
__________________

diamondrmp is offline   Reply With Quote
Old 07-13-2010, 08:12 PM   #4
51.50
Member
 
Join Date: Dec 2009
Location: Dallas
Posts: 43
Default Speedo Problem

There was a recall on the 99/01 Speedo unit. Victory was having the dealers replace the instrument cluster at no charge.The upgraded units have green turn signal arrows while the original had amber. The problems were moisture getting into the unit as well as the odometer resetting itself to Zero. There were also problems with the handle bar switches having intermittent contact from dirt and moisture. I am referring to the switches that control the digital readout. I hope this helps.

Last edited by 51.50; 07-13-2010 at 08:55 PM. Reason: more detail
51.50 is offline   Reply With Quote
Old 07-13-2010, 08:40 PM   #5
kevinx
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At home, or work
Posts: 2,028
Default

Does the odo change or does it remain static at whatever milage you were at??
kevinx is offline   Reply With Quote
Old 07-14-2010, 01:38 PM   #6
Shanesr
Junior Member
 
Join Date: May 2010
Posts: 16
Default My switch,

The switch that you resets the milage on the odometer, (on the clutch side) doesnt work, my turn signal arrows are green so I guess my bike has had the upgrade, my speed -o- has stopped working one other time since I cleanned it. I reached down and turned the key switch off and then back on while riding, the speed-o- starting working again, but the tact was only showing about half of the rpm's
for the rest of the ride, Once I shut it off and started again everything was working fine,
Shanesr is offline   Reply With Quote
Old 08-04-2010, 07:51 PM   #7
AnnArbor_707
Member
 
Join Date: May 2010
Posts: 54
Default

I have a 2002 V92 TC Deluxe and the speedo / Odometer is the only thing not working. The digital readout is fine and so is the fuel gauge. Anyone know anything about the '02 ?? Seems weird they'd have a big recall through 2001, then have a similar issue in 2002. No reflection in the design department ? Or maybe I'm just unlucky...
AnnArbor_707 is offline   Reply With Quote
Old 08-04-2010, 08:00 PM   #8
kevinx
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At home, or work
Posts: 2,028
Default

Quote:
Originally Posted by AnnArbor_707 View Post
I have a 2002 V92 TC Deluxe and the speedo / Odometer is the only thing not working. The digital readout is fine and so is the fuel gauge. Anyone know anything about the '02 ?? Seems weird they'd have a big recall through 2001, then have a similar issue in 2002. No reflection in the design department ? Or maybe I'm just unlucky...
Recall on the earlier models was caused by an engineering bobo. Instead of storing the odo in hard memory. Vic used a powered memory that essentialy used a watch battery to keep the memory in place. Battery goes bad, and odo goes to ZERO. The DOT thought it was a bad idea.
99% of the time speedo, and odo stop working on a 02-06 Vic. It is the speed sensor PN 4011111
If the switches do not work. They need to be cleaned
kevinx is offline   Reply With Quote
Old 08-05-2010, 05:59 PM   #9
AnnArbor_707
Member
 
Join Date: May 2010
Posts: 54
Default

Quote:
Originally Posted by kevinx View Post
Recall on the earlier models was caused by an engineering bobo. Instead of storing the odo in hard memory. Vic used a powered memory that essentialy used a watch battery to keep the memory in place. Battery goes bad, and odo goes to ZERO. The DOT thought it was a bad idea.
99% of the time speedo, and odo stop working on a 02-06 Vic. It is the speed sensor PN 4011111
If the switches do not work. They need to be cleaned
Kevin - You're the man! Thanks so much for taking the time to reply to this thread. Can't say in words how much help you've been. Looks like I can get one for $75 on ebay. The next question for me is do I really want to replace it - since the odometer is shut down I'm not putting miles on the bike
.
By the way - Kevin - You don't have to answer, but are you a mechanic ? You seem to have all the answers!
AnnArbor_707 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum