Fuel pump - Victory Forums - Victory Motorcycle Forum
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games
Go Back   Victory Forums - Victory Motorcycle Forum > Victory Motorcycles > Victory Hammer Forum

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-16-2011, 09:37 PM   #1
Randy
Member
 
Join Date: May 2011
Location: Columbia Missouri
Posts: 49
Default Fuel pump

Bike started to buck a little today and hesitate on take off. Made it out to the dealership and now it won't start. No pressure at all from the fuel pump. Without the bike for a few days till they get a pump. Lucky for me it's under warranty, so no dime out of my pocket. For those of you who run in to this problem out of warranty, the VicShop will rebuild them quickly for MUCH less than the 500-600$ a fuel pump costs.
I'm just glad I made it to the dealer, earlier I was out in the boonies riding and would of been really hot/sweaty and mad trying to find a place to push the bike to.
__________________
2012 Cross Country Tour--Pearl White
2007 Hammer-Traded
2009 Kawasaki Versys-traded
2009 Kawasaki KLX250s-traded
Randy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-17-2011, 06:35 AM   #2
Oldcarjunkie
Senior Member
 
Join Date: Feb 2011
Location: Pasadena Md
Posts: 133
Garage
Default

Glad you made it in and its under warranty, I replaced mine myself and had Rylan rebuild the pump, depending on what needs to be replaced will tell you the cost, mine was right around 300. And he is smoking fast on turn around time!
__________________
________________________________________
2004 Vegas
Oldcarjunkie is offline   Reply With Quote
Old 07-17-2011, 07:29 AM   #3
Randy
Member
 
Join Date: May 2011
Location: Columbia Missouri
Posts: 49
Default

Thanks Oldcarjunkie!!
One of our club members also recommended him so I will try to get my old pump and send it to him for a backup if needed. I'm just glad it's under warranty, I made it to the shop and didn't have to do the embarassing push of shame. Only 2400 miles on the bike, surprised it failed but it has been sitting for awhile before I bought it. Maybe something dried up, cracked and gave out, diaphram seal? I'll find out though if I send it to Rylan.
__________________
2012 Cross Country Tour--Pearl White
2007 Hammer-Traded
2009 Kawasaki Versys-traded
2009 Kawasaki KLX250s-traded
Randy is offline   Reply With Quote
Old 07-17-2011, 07:54 AM   #4
Oldcarjunkie
Senior Member
 
Join Date: Feb 2011
Location: Pasadena Md
Posts: 133
Garage
Default

Quote:
Originally Posted by Randy View Post
Thanks Oldcarjunkie!!
One of our club members also recommended him so I will try to get my old pump and send it to him for a backup if needed. I'm just glad it's under warranty, I made it to the shop and didn't have to do the embarassing push of shame. Only 2400 miles on the bike, surprised it failed but it has been sitting for awhile before I bought it. Maybe something dried up, cracked and gave out, diaphram seal? I'll find out though if I send it to Rylan.
The Sitting is exactly what did it, I replaced my pump at 417 miles, this year on the 2004 that i just bought, The guy left gas in it and never rode the bike as told by the mileage. It gums up the pump. Get the pump from the dealer cause they are not going to replace the pump on the assembly anyway, they will replace the Whole assembly. Before you send to Rylan, you might also try to soak it in some seafoam and tap it with a hammer, you might be able to free it up yourself, unfortunately, that was not the case for mine, mine was toast.
__________________
________________________________________
2004 Vegas
Oldcarjunkie is offline   Reply With Quote
Old 07-17-2011, 11:36 AM   #5
Randy
Member
 
Join Date: May 2011
Location: Columbia Missouri
Posts: 49
Default

Mine was brand new with only four miles on it, dealer left over, but I guess the sitting even without fuel is what did it in

Missed a breakfast ride this am before it got too hot to ride but did get all the weeds pulled in the garden. Lookin forward to getting my bike back. Had over 12k on my Versys when I traded for the vic, it never had a problem. Hoping this is just a fluke of being a left over model, not really wanting to have any problems---one of the reasons I went for a Vic!!
__________________
2012 Cross Country Tour--Pearl White
2007 Hammer-Traded
2009 Kawasaki Versys-traded
2009 Kawasaki KLX250s-traded
Randy is offline   Reply With Quote
Old 08-16-2011, 03:27 AM   #6
Mighell.connor
Junior Member
 
Join Date: Jul 2011
Location: NJ
Posts: 9
Post Re:

I think there is too much resistance in the connections due to dirt/gunk/whatever. Therefore not enough current reaches the pump to make it start. If you connect directly whilst fitted.
Mighell.connor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:30 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum