99 V92c Charging Issues - Victory Forums - Victory Motorcycle Forum
» Insurance
» Sponsors
» Our Partners
»ATV Reviews
»Motorcycle Games
Go Back   Victory Forums - Victory Motorcycle Forum > Victory Motorcycles > Victory Tech and Performance Section

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-03-2011, 07:58 PM   #1
jkbcby
Junior Member
 
Join Date: Aug 2011
Location: De Land, Fl
Posts: 8
Unhappy 99 V92c Charging Issues

I have a 99 V92c, Stage 1 slip-ons and K&N, I have a chip in the mail to fix the fuel mapping. About 1 month ago, the battery died and I replaced it with a new on. The alt was reading as high as 14v with the old battery. It had a bad cell and I though that was allowing it to over charge. The new one (charged properly on a charger before install) has only gone to 12.2, which makes me think the system (rec/reg and stator) was working fine. Last weekend I rode about 150mi and it showed 10.8-11.5 throughout the day. Today, it wouldnt go above 11.0 and was normally at 10.4-10.8 under a full load. The last stop of the day (local riding, maybe 20mi) the bike wouldnt start. The reading was 10.5-10.8 and not enough juice to turn the motor over. The lights all work, but I got the solenoid *click, click click* and had to jump it to get it home. Once here, it again wouldnt start and was showing 10.8. I dont believe the battery is the issue now. I remove it and keep it on a battery tender when I wont be riding the bike for 7 or more days. Does this sound like a bad rectifer/regulator, stator, coil, or (god forbid) the ecu???

Thanks in advance for the responses!

99 V92c
and a 01 Sv650s
jkbcby is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-03-2011, 09:03 PM   #2
CrossRoads
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,811
Default Technical Question

This is a technical question, so I have moved the thread to the Victory Tech and Performance Section.
__________________
Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
HID upgrade kits: VictoryHID.com
------------------------------------------------------------------------------

------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline   Reply With Quote
Old 09-03-2011, 09:09 PM   #3
kevinx
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At home, or work
Posts: 2,019
Default

If I were to just guess. I would say it is a regulator. If you plan on keeping the bike. You should go to a 38 amp system upgrade
__________________
I'm not an asshole...I just type that way
kevinx is offline   Reply With Quote
Old 09-03-2011, 11:52 PM   #4
diamondrmp
The Diamond
 
diamondrmp's Avatar
 
Join Date: Aug 2009
Location: N. California via Los Angeles, CA
Posts: 4,004
Garage
Default

Welcome to the Victory Forums.

A few helpful pointers,
  • Please take the time to read the “Sticky” threads in the “Victory Forums Rules and New Members Introductions” forum. This will help you out a LOT with the Victory Forums.

  • The Search feature is your friend! You will find the answers to a lot of your questions by using it.

  • If you are asking questions that are of a technical/mechanical/electrical/performance nature, please place them in the “Victory Tech and Performance” forum. This will speed up a response. Placing them in the model specific forum can delay a response.

Please add the year and model of your bike to your signature, so we know how to help when you ask a question!
__________________

diamondrmp is offline   Reply With Quote
Old 09-05-2011, 12:46 PM   #5
ray2001
Junior Member
 
Join Date: Jul 2009
Posts: 17
Default

Do the charging system upgrade, it really makes a huge difference in performance and I now don't have to worry about being stranded. Cost with oil change was about480.00
ray2001 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum