Hawg Wired Mount & Rockford Amp - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 02-15-2015, 09:06 AM Thread Starter
Senior Member
 
Kingsrule5's Avatar
 
Join Date: Aug 2014
Location: Tempe,AZ
Posts: 399
Garage
Default Hawg Wired Mount & Rockford Amp

So I bought a PBR300x2, alpine type S speakers, wiring kit and hawg wired mount off somebody on here.

When looking at the mount and the amp I realized there are only the 2 holes for mounting on the bracket and those align with the holes on the bike. Unfortunately the bolts for that are bigger than the openings on the amp so can't share that, or so it seems.

Should I just drill new holes in the mount for the amp?


Sent from Motorcycle.com Free App

2014 XC Boss Blue/Gloss Black
Tri-Ovals
Lloydz ATS +4
Lloydz Air Filter
1/4 turn throttle
PCV
PBR300x2+Alpine SPS-510
Goody Lowers
Klock Works windscreen

2006 Suzuki GSXR 600
Kingsrule5 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-15-2015, 10:55 AM
Lifetime Premium
 
Travis P's Avatar
 
Join Date: May 2013
Posts: 4,498
Default

I think the idea is to drill holes for your specific amp... At least the one I purchased from Vtwin Audio is that way.
Travis P is offline  
post #3 of 6 (permalink) Old 02-15-2015, 11:50 AM Thread Starter
Senior Member
 
Kingsrule5's Avatar
 
Join Date: Aug 2014
Location: Tempe,AZ
Posts: 399
Garage
Default

Ok. I just wasted to make sure I wasn't missing some sort of easy way to get it on there.


Sent from Motorcycle.com Free App

2014 XC Boss Blue/Gloss Black
Tri-Ovals
Lloydz ATS +4
Lloydz Air Filter
1/4 turn throttle
PCV
PBR300x2+Alpine SPS-510
Goody Lowers
Klock Works windscreen

2006 Suzuki GSXR 600
Kingsrule5 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-15-2015, 12:46 PM
Member
 
109rfan's Avatar
 
Join Date: Dec 2010
Posts: 66
Default

I thought there was possibly self tapping screws if not drill it how you would like. The 2 holes are for fairing
109rfan is offline  
post #5 of 6 (permalink) Old 02-15-2015, 12:55 PM Thread Starter
Senior Member
 
Kingsrule5's Avatar
 
Join Date: Aug 2014
Location: Tempe,AZ
Posts: 399
Garage
Default

The two screws with the mount were for mounting to the bike doesn't seem like it would work for the amp. I didn't see any self tapping.


Sent from Motorcycle.com Free App

2014 XC Boss Blue/Gloss Black
Tri-Ovals
Lloydz ATS +4
Lloydz Air Filter
1/4 turn throttle
PCV
PBR300x2+Alpine SPS-510
Goody Lowers
Klock Works windscreen

2006 Suzuki GSXR 600
Kingsrule5 is offline  
post #6 of 6 (permalink) Old 02-15-2015, 01:07 PM
Member
 
109rfan's Avatar
 
Join Date: Dec 2010
Posts: 66
Default

Maybe in with the amp. Sorry couldn't be of not help. I ended up using witchdoctors amp and mount. It wouldn't hurt to drill holes in the mount to provideore airflow for the amp. Figure if drilling it out already.
109rfan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome