Need help...quick..died...fuel starved - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 28 (permalink) Old 08-01-2015, 07:08 PM Thread Starter
Member
 
Join Date: Jul 2014
Location: Richmond IL
Posts: 66
Default Need help...quick..died...fuel starved

Hey guys
Slammed on brakes at stoplight and bike died. Wont restart. Like starving for fuel. Need advice. Checked fuse...its ok.
Plz help
kllrbee is offline  
Sponsored Links
Advertisement
 
post #2 of 28 (permalink) Old 08-01-2015, 07:12 PM Thread Starter
Member
 
Join Date: Jul 2014
Location: Richmond IL
Posts: 66
Default

Fuel pump wont kick on when turn key on
kllrbee is offline  
post #3 of 28 (permalink) Old 08-01-2015, 07:17 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,947
Default

what year and model

is the battery cables tight. 10mm wrench
think the fuel pump runs off relay not a fuse.
Is bike in neutral
you really aren't telling us much

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
post #4 of 28 (permalink) Old 08-01-2015, 07:20 PM Thread Starter
Member
 
Join Date: Jul 2014
Location: Richmond IL
Posts: 66
Default

2014 XC...battery cables tight....i saw the relay...how do I check if bad relay tho?
kllrbee is offline  
post #5 of 28 (permalink) Old 08-01-2015, 07:20 PM Thread Starter
Member
 
Join Date: Jul 2014
Location: Richmond IL
Posts: 66
Default

Bike is in nutral...
kllrbee is offline  
post #6 of 28 (permalink) Old 08-02-2015, 07:14 AM
Senior Member
 
Amboymike's Avatar
 
Join Date: Mar 2015
Location: NE, Ohio
Posts: 227
Default

maybe the "tip over sensor" jarred loose????

_____________________________________


2012 Crossroads
Amboymike is offline  
post #7 of 28 (permalink) Old 08-02-2015, 07:38 AM
Lifetime Premium
 
Motorbikerx's Avatar
 
Join Date: Dec 2013
Location: Gold Coast, Australia.
Posts: 8,647
Garage
Default

Kill switch on?

Victory Vegas 2010
Lloydz 109"cube big bore
" " 495 cams
" " TorqueTubes
" " timing wheel @4 deg.
" " Primary plate
" " IAV
RPW Slash pipes
PCV
Progressive 465 rear shock
Kingpin USD Forks
18" XC front wheel
1 3/4" 'Burleigh Bars'
Stebel air horn
12.106 @110.90mph
114/123

Victory Cross Country 2010 (106)
Lloyds air filter
" " VM1 Cams
Home gutted exhaust
Maximus
Both tuned by [email protected] Dyno
110/116

Gold Coast
Australia
Motorbikerx is offline  
post #8 of 28 (permalink) Old 08-02-2015, 04:37 PM
Lifetime Premium
 
WABlue's Avatar
 
Join Date: Aug 2014
Location: Perth, Western Australia
Posts: 61
Default Volt meter

Quote:
Originally Posted by kllrbee View Post
2014 XC...battery cables tight....i saw the relay...how do I check if bad relay tho?
You could try a test light but a volt meter will be better on each post.


2013 Cross Country Tour
Lloyds Air Cleaner
Lloyds Timing Wheel
PCV
Thrush exhaust Mod
O2 sensors disconnected
1/4 turn throttle ring
195/55/16 rear tyre
WABlue is offline  
post #9 of 28 (permalink) Old 08-02-2015, 04:54 PM Thread Starter
Member
 
Join Date: Jul 2014
Location: Richmond IL
Posts: 66
Default

So I ended up getting a tow home last nite. As I was waiting, i had the bike hazards on so battery died. I took off cables and fully charged it hoping that maybe it would teset the tilt sensor (if that was the problem). No good....bike still acts like starving for fuel.
Only mods ive done is lloyds air filter and atom bombs.
I took out a plug thinking that maybe I choked it when I stopped suddenly. Plugs not fouled or wet....actually looks slightly lean...but not bad....looks like it should.
Im thinkin its the pump....whats the "easiest" way to go about testing it on this bike?
I already have the seat and wedges off....and tank is unbolted by the seat so most lines should be accessible.
Also...just throwing this out there if it comes to it. I am still under warranty....ive had for just over a year, but my dealer gave me a 2nd year with $50 deductible. Not sure if this was somethin my dealer does or if they all do....but thought I would mention it. Funny thing is that Ive never owned any car or bike that I had a warranty on....Dont even know how to use it....haha.
I assume i just call the dealer....but do I still have to pay for a tow there? Sorry if that seems like a dumbass question....but like I said....never had a warranty.
Never had to have a vehicle towed either....another first.
Lots of questions....help me out here....thnx guys.
kllrbee is offline  
post #10 of 28 (permalink) Old 08-02-2015, 04:56 PM
Senior Member
 
kodiakwood2's Avatar
 
Join Date: Jun 2014
Location: Walland Tennessee
Posts: 471
Garage
Default

This just happened to me, pulled in clutch, bike died, cranks over right, but no sound that the fuel rail is pressurized when you flip the kill switch. Turns out my fuel pump died. I hope the best for you.
Fortunately mine was covered under my extended warranty, $375 for the pump plus labor.

Let us know what happens

Eastern Tennessee
Current ride
2018 Goldwing tour
Gone but not forgotten...
2014 Cross Country
Black/Chrome
Ultimate seat and driver backrest, Vic passenger backrest, Custom pinstriping by Dave Davies
Lloyds PTS @+5, Lloyds air filter, PC-V, Miller Mufflers, Lloyds Dyno-Tune,
Lloyds quarter turn throttle ring, Victory HID's, RicZ lay down bracket, Barnett "Stealth" clutch cable
kodiakwood2 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome