Speedo digital WTF? - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 16 (permalink) Old 08-27-2015, 01:20 PM Thread Starter
Senior Member
 
Donzo's Avatar
 
Join Date: May 2011
Location: NorCal
Posts: 436
Default Speedo digital WTF?

My speedo digital display is messed up. The far right side of the readout is gone. So now if is supposed to be a 0 it looks like a C - the far right line is not displaying....... anyone else have this prob?

I hope it does not continue to "degrade" or I will bee buying a new speedo.....

Question: If you replace the speedo will it still show current milage? I don't know if the bike computer stores that info or if it is in the speedo itself?

2010 Crossroads
Midnight Cherry

No Rice
No Pork
Just Beef

Enjoy the miles....we only get so many!
Donzo is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 08-27-2015, 02:07 PM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,368
Garage
Default

Is this for a Cross Roads?



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +3, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is online now  
post #3 of 16 (permalink) Old 08-27-2015, 02:32 PM Thread Starter
Senior Member
 
Donzo's Avatar
 
Join Date: May 2011
Location: NorCal
Posts: 436
Default

Yes a 2010 XR. With 57,000 miles - still like new....except for this.

2010 Crossroads
Midnight Cherry

No Rice
No Pork
Just Beef

Enjoy the miles....we only get so many!
Donzo is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 08-27-2015, 03:06 PM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,368
Garage
Default

I've had my LCD items where the screen does exactly what you are describing. Could be bad electronics, moisture, etc. No way to know for sure until it's looked at.

Don't know about the odo thing...



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +3, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is online now  
post #5 of 16 (permalink) Old 08-28-2015, 08:04 PM Thread Starter
Senior Member
 
Donzo's Avatar
 
Join Date: May 2011
Location: NorCal
Posts: 436
Default

Quote:
Originally Posted by broggyr View Post
I've had my LCD items where the screen does exactly what you are describing. Could be bad electronics, moisture, etc. No way to know for sure until it's looked at.

Don't know about the odo thing...
Thanks for the reply. It's not just the odometer, it's the RPM, Voltage, miles, etc. I will live with it for now. Hopefully it won't continue to effect more of the LCD display.

I guess no one here knows if the computer or the speedo itself stores milage. I will look else where for that info.
Thanks again,
Don

2010 Crossroads
Midnight Cherry

No Rice
No Pork
Just Beef

Enjoy the miles....we only get so many!
Donzo is offline  
post #6 of 16 (permalink) Old 08-29-2015, 05:41 AM
Member
 
Bhunt19's Avatar
 
Join Date: Sep 2014
Location: Newburgh NY
Posts: 89
Red face

I would imagine that your display is the same as mine, although different model bikes. I just had my inst cluster replaced under warranty. The mileage info is NOT stored anywhere and can NOT be reset in the new one. If you replace it, you'll be starting at 0, literally!!

2014 XCT, Black, Stage 1 tune w/Tri Ovals, 1/4 turn, Lloyds A/F, ATS @+4

2006 VStar Custom
Bhunt19 is offline  
post #7 of 16 (permalink) Old 08-29-2015, 08:48 AM Thread Starter
Senior Member
 
Donzo's Avatar
 
Join Date: May 2011
Location: NorCal
Posts: 436
Default

Quote:
Originally Posted by Bhunt19 View Post
I would imagine that your display is the same as mine, although different model bikes. I just had my inst cluster replaced under warranty. The mileage info is NOT stored anywhere and can NOT be reset in the new one. If you replace it, you'll be starting at 0, literally!!

Thanks for the info! I will keep my current speedo if the readout does not continue to fail....but was curious if it was storing or just displaying. Not to bad 57,000 miles and this is the only problem I've had with the bike.

2010 Crossroads
Midnight Cherry

No Rice
No Pork
Just Beef

Enjoy the miles....we only get so many!
Donzo is offline  
post #8 of 16 (permalink) Old 08-29-2015, 10:35 AM
Senior Member
 
Join Date: Sep 2014
Location: Hendersonville, NC in summers and The Villages, FL in winters
Posts: 1,460
Default

And perhaps soon your bike will have 0 miles

G'day,

Vinish
Vinish is online now  
post #9 of 16 (permalink) Old 08-29-2015, 10:57 AM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,912
Garage
Default

Quote:
Originally Posted by Bhunt19 View Post
I would imagine that your display is the same as mine, although different model bikes. I just had my inst cluster replaced under warranty. The mileage info is NOT stored anywhere and can NOT be reset in the new one. If you replace it, you'll be starting at 0, literally!!
There might be one way to adjust the mileage to what the existing speedo says and that is with the Digital Wrench the dealer has.

You could ask KevinX. I would not depend on a local dealer knowing unless they have dealt with this before.

Sadly; anything electrical or mechanical will wear out eventually. Sometimes prematurely like what is happening here.
BBob is online now  
post #10 of 16 (permalink) Old 08-29-2015, 12:31 PM
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default

I have had mine replaced TWICE on my 2010 XR.....
I asked the dealer whats up with that after the second time and he said just trey to keep the bike out of the weather....
I live in hot, rainy FL.....

2010 Cross Roads
Vic HP air filter
Stage 1
D&D slash cut mufflers
Lloyd's Adjustable Timing Wheel @ 4
Kuryakyn Engine Guard Driving lights
Sabertooth auxiliary tail lights
7jurock custom WS with vent
Cee Bailey lowers
Ness Tear Drop mirrors
45caldan is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome