Fuel pump / oxygen sensors - Victory Forums - Victory Motorcycle Forum
 1Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 11 (permalink) Old 10-29-2015, 01:17 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: St.Augustine , fl
Posts: 18
Default Fuel pump / oxygen sensors

I just traded my Jackpot for a 2012 Cross country. Have put 1000 miles on it , bike runs great , Put a timing wheel on at + 4 degrees, bike ran better. Everyone kept saying to unplug the 02 Sensors. I did, Bike ran even better. Took a test ride today down A1A by Marineland about 18 miles. "Bike" stopped dead like it was out of gas. Tried to restart, only turned over would not fire. tried several times to restart but nothing. Could not hear the fuel pump working. Called AAA and while waiting checked the fuse box found the fuel pump fuse blown. Replaced the fuse "RAN LIKE a CHAMP." Was it just bad timing or could the 02 Sensor disconnect have caused the problem ??? Any Ideas ???
Thanks Tom

2014 JackPot
STONEFACE is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 10-29-2015, 02:12 PM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,308
Garage
Default

O2 disconnect won't affect your fuel pump fuse, it's no where near the same circuit. Coincidence.
vindex1963 likes this.



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +5, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is online now  
post #3 of 11 (permalink) Old 10-29-2015, 03:39 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: St.Augustine , fl
Posts: 18
Cool

Thanks,
I was hoping for that answer. Have had 20 odd bikes over the years and never blew a fuse.

2014 JackPot
STONEFACE is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 10-29-2015, 04:06 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

What EXACTLY were you doing the MOMENT BEFORE the fuse blew??

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #5 of 11 (permalink) Old 10-29-2015, 05:20 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: St.Augustine , fl
Posts: 18
Default

Riding down the highway at 45mph in 4th gear about to speed up and shift gears.

2014 JackPot
STONEFACE is offline  
post #6 of 11 (permalink) Old 10-29-2015, 05:27 PM
Lifetime Premium
 
Motorbikerx's Avatar
 
Join Date: Dec 2013
Location: Gold Coast, Australia.
Posts: 8,626
Garage
Default

How many miles on it ,OP.
and could a dirty fuel filter be starting to restrict flow, @kevinx
You had a spare fuse I presume?
Motorbikerx is offline  
post #7 of 11 (permalink) Old 10-29-2015, 05:55 PM Thread Starter
Junior Member
 
Join Date: Sep 2014
Location: St.Augustine , fl
Posts: 18
Cool

17,000. Nothing out of the ordinary prior to this.

2014 JackPot
STONEFACE is offline  
post #8 of 11 (permalink) Old 10-29-2015, 07:16 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,056
Default

Have you checked the battery terminals? They have a tendency to loosen. Place external star washers under the bolts to help with keeping 'em tight.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is online now  
post #9 of 11 (permalink) Old 10-29-2015, 07:34 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Quote:
Originally Posted by Motorbikerx View Post
How many miles on it ,OP.
and could a dirty fuel filter be starting to restrict flow, @kevinx
You had a spare fuse I presume?
Dirty filter won't do it

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #10 of 11 (permalink) Old 10-30-2015, 02:52 AM
Member
 
Dave S's Avatar
 
Join Date: Aug 2015
Location: England
Posts: 32
Default

were you lw on fuel ? My Buell did it several times about 10 miles after the low fuel light came on, the pump over heats on Buells.

2012 Cross Country Tour
Dave S is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome