2015 XCT LED Floorboard Lights - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 03-03-2016, 03:53 PM Thread Starter
Senior Member
 
Join Date: Sep 2010
Location: Florida
Posts: 221
Default 2015 XCT LED Floorboard Lights

I put LED's on my floorboard, 12" long from Autozone. I installed them like Witchdoctors shows. I do like his because they are longer, but I went this route instead. I wanted them as run/turn signals. First tried the Custom Dynamics Dual Converter per my conversation with their sales. They didn't work. Called them back and spoke with a guy named Junior, he said that because of the voltages Victory runs, I would need the Eclipse 2 converter (part #EPZ 2). Wired them in this morning and all seems well. The LED's are on as running lights at 100%. When you activate a turn signal the turn signal goes out, a wig-wag effect. The Eclipse 2 is rated for 300MA, the LED's I got from Autozone are rated 240MA.
The customer service from Custom Dynamics was excellent !!!! (and no additional cost I might add)

2015 XCT Two Tone White/Gray
Ultimate Seat & Backrest
Custom Dynamics Non-Sequential License Plate Frame
Hyper-Lites
Kuryakyn #4178 Windshield Bag
Victory Bag Guards
Custom Dynamic Cool Magic Bullet LED Running Lights
+2" Back Bars
Victory Highway Pegs #2874837 & Z-Bracket
Kuryakyn Sabertooth LED's

Traded for a 2015 Cross Country Tour on 8-31-15
Previous bike was a 2010 Victory Cross Country-Midnight Cherry, had 54,xxx+ trouble free miles. Just needed a change & got a great deal.
rdeerx is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-03-2016, 04:15 PM
Senior Member
 
Join Date: Jul 2014
Posts: 1,125
Default

Quote:
Originally Posted by rdeerx View Post
The customer service from Custom Dynamics was excellent !!!! (and no additional cost I might add)
I'll second that. I just got a replacement set of lights from them under warranty, even though I ordered them almost 4 years ago. They are a good company from my experience.
vcc14 is offline  
post #3 of 3 (permalink) Old 03-06-2016, 05:08 PM
Member
 
VMChief's Avatar
 
Join Date: Sep 2012
Location: Crestview, Florida
Posts: 41
Default

Quote:
Originally Posted by rdeerx View Post
I put LED's on my floorboard, 12" long from Autozone. I installed them like Witchdoctors shows. I do like his because they are longer, but I went this route instead. I wanted them as run/turn signals. First tried the Custom Dynamics Dual Converter per my conversation with their sales. They didn't work. Called them back and spoke with a guy named Junior, he said that because of the voltages Victory runs, I would need the Eclipse 2 converter (part #EPZ 2). Wired them in this morning and all seems well. The LED's are on as running lights at 100%. When you activate a turn signal the turn signal goes out, a wig-wag effect. The Eclipse 2 is rated for 300MA, the LED's I got from Autozone are rated 240MA.
The customer service from Custom Dynamics was excellent !!!! (and no additional cost I might add)
Can you post a picture? I would love to see what it looks like.

2012 Cross Country
2008 Vegas Low (for the wife)
2006 Yamaha V-Star 650 (parked for now, but will train the 19 yr-old boy on fixing and riding before long)
Crestview, Florida/Eglin AFB (USAF)
VMChief is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome