Radio Reception - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 12 (permalink) Old 04-17-2016, 10:23 PM Thread Starter
Senior Member
 
djh3's Avatar
 
Join Date: Oct 2015
Location: Central Fl
Posts: 1,073
Default Radio Reception

I have only had my XCT since January. But oh say a month or so ago the radio reception seems to have got worse. Now local station wont even come in very clear. The display sometimes shows the station call letters and artist and song. But I would say more times than not nothing shows. And the reception is bad. Is this something that maybe the dealer can correct with a firmware update or something. I know the reception on my RSV was not that great either, but at least I could get the local stations in town.

2013 XCT added Jan 2015
pull back bars, passenger arm rests, HID Low beam, Silverstar Ultra headlight high beam,Drag Specialties Pillow Top seat with driver backrest. Glasspack mod Mufflers.
2009 Royal Star Venture-Traded Jan 2016

Trailers are for when it's broke aint it?
djh3 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 04-18-2016, 12:51 AM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,765
Garage
Default

Since it was better at one time and not long ago; I'd be thinking something on the bike has changed. Maybe a connection issue where the antenna plugs in or something between there and the head unit (stereo).
BBob is offline  
post #3 of 12 (permalink) Old 04-18-2016, 06:33 AM Thread Starter
Senior Member
 
djh3's Avatar
 
Join Date: Oct 2015
Location: Central Fl
Posts: 1,073
Default

Yup my first thoughts too. I was under the fairing installing some charging cables and fixing a loose wire issue and installing the plug for the bluetooth output. It was a week or better after that. But still I went back in to see if maybe something got disturbed. I took the antenna apart, cleaned it and installed some dielectric grease. No better. It does have the short antenna, but it has been there from the git go.

2013 XCT added Jan 2015
pull back bars, passenger arm rests, HID Low beam, Silverstar Ultra headlight high beam,Drag Specialties Pillow Top seat with driver backrest. Glasspack mod Mufflers.
2009 Royal Star Venture-Traded Jan 2016

Trailers are for when it's broke aint it?
djh3 is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 04-19-2016, 02:05 PM
Senior Member
 
Atbyrne's Avatar
 
Join Date: Sep 2011
Location: corydon, in
Posts: 812
Garage
Default

my radio is way worse when I have the ipod olugged in.

2011 Cross Country
PCV with Vic filter
Witchdoctors Muscle Mufflers
Painted inner fairing
Magnum 21" Wheel and Fender
Custom mounted CVO Tour Pak
Vicbaggers Bars, speaker grills,
and bezels
Atbyrne is offline  
post #5 of 12 (permalink) Old 04-19-2016, 03:59 PM Thread Starter
Senior Member
 
djh3's Avatar
 
Join Date: Oct 2015
Location: Central Fl
Posts: 1,073
Default

Quote:
Originally Posted by Atbyrne View Post
my radio is way worse when I have the ipod olugged in.
HMMM thats odd. Maybe I'll unplug it and see if it changes things for me. Thanks for the heads up. Seems weird it would do that, but I suppose if you got the ipod plugged up you probably aint gonna need the radio.

2013 XCT added Jan 2015
pull back bars, passenger arm rests, HID Low beam, Silverstar Ultra headlight high beam,Drag Specialties Pillow Top seat with driver backrest. Glasspack mod Mufflers.
2009 Royal Star Venture-Traded Jan 2016

Trailers are for when it's broke aint it?
djh3 is offline  
post #6 of 12 (permalink) Old 04-19-2016, 05:19 PM
Lifetime Premium
 
luvmyride's Avatar
 
Join Date: Aug 2013
Location: Evansville, IN
Posts: 538
Default

Quote:
Originally Posted by Atbyrne View Post
my radio is way worse when I have the ipod olugged in.
Same here... I unplug it around town and get decent reception (also shorty antenna), but when I get out of town I use the iPod so I pull of and plug it in



2013 Black XC.
RF PBR300x2, Hybrid Audio Imagine 6.5",
Atom Bomb pipes, PCV, Lloydz AF & ATS (95 HP 110 TQ)
Victory Hard Lowers
Windvest 9" flip
Avon Boss Heated Grips
Hard mounted Garmin 665LM
VicBaggers:
23" Double Edge front wheel
+6 degree trees
Ridgeback front fender
Bag fillers
Tarzanz +2" bars
License Plate Relo kit
Contrast cut speaker grills and exhaust tips
Contrast cut cam bolt covers
luvmyride is offline  
post #7 of 12 (permalink) Old 04-19-2016, 06:39 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

do you have extended warranty and does it cover radio.
you can send your radio in and have them look at it.


RadioSound - Customer Service

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #8 of 12 (permalink) Old 04-20-2016, 08:44 AM
Senior Member
 
unbidden's Avatar
 
Join Date: Jun 2014
Posts: 131
Default

I solve bad radio reception by using my phone and Bluetooth to log into the station of choice; I have unlimited data. Other than that, a longer antenna would help and if using any added led lights, try turning them off.
unbidden is offline  
post #9 of 12 (permalink) Old 04-30-2016, 08:05 AM
Member
 
Join Date: Jun 2013
Location: Norman, Ok.
Posts: 75
Default

Quote:
Originally Posted by djh3 View Post
HMMM thats odd. Maybe I'll unplug it and see if it changes things for me. Thanks for the heads up. Seems weird it would do that, but I suppose if you got the ipod plugged up you probably aint gonna need the radio.
I had a similar problem.

The 12v to usb adapter I was using just killed the FM radio reception. Come to find out its a common thing. Google it.
It took me several tries at the local auto parts store to find one that worked properly.
Had the same problem in my truck as well.

2013 Victory Cross Country Tour.
2005 Hayabusa
Truckracer is offline  
post #10 of 12 (permalink) Old 05-01-2016, 08:11 PM Thread Starter
Senior Member
 
djh3's Avatar
 
Join Date: Oct 2015
Location: Central Fl
Posts: 1,073
Default

Quote:
Originally Posted by Truckracer View Post
I had a similar problem.

The 12v to usb adapter I was using just killed the FM radio reception. Come to find out its a common thing. Google it.
It took me several tries at the local auto parts store to find one that worked properly.
Had the same problem in my truck as well.
So the 12v adapter may be source of problem? I grabbed power right off the current plug in fairing on back side.

2013 XCT added Jan 2015
pull back bars, passenger arm rests, HID Low beam, Silverstar Ultra headlight high beam,Drag Specialties Pillow Top seat with driver backrest. Glasspack mod Mufflers.
2009 Royal Star Venture-Traded Jan 2016

Trailers are for when it's broke aint it?
djh3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome