Dash Lights...Not Battery Connections - Victory Forums - Victory Motorcycle Forum
 2Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 13 (permalink) Old 05-11-2016, 05:24 AM Thread Starter
Member
 
DMC.Thumper's Avatar
 
Join Date: Jan 2012
Location: Maine
Posts: 39
Default Dash Lights...Not Battery Connections

2011 XC - 25,000 miles.....Ok here is what I have going on. I've been getting the bike ready for the season, going through the normal maintenance and such (I'm in Maine - bike season doesn't really kick off until June).

Anyway I took it for a short ride yesterday and noticed that the left blinker indicator was on. Then the cruise indicator started flashing. Blinkers and all lights still worked. So I went to an XC page on Facebook and someone suggested to check the battery connections. I hadn't gotten there yet so, I dug in and found that they were a little bit loose. I tightened them up, used lock tight and started the bike. Everything appeared normal. Problem solved...so I thought.

So...this morning I'm bringing the bike to work, and a few miles down the road the light comes back on. Then my radio display starts flashing and scrolling through my iPod play list all on it own. The radio continued to work fine. Shut the bike off, and then started back up and all appears normal again.

The bike did get stuck in a heavy rain storm Saturday, but it's been dry since.

I was planning on riding the bike to a Dr. Appt. an hour away this afternoon (supposed to reach 60!!!), but wondering if I should.

Anyway...thoughts????? THANKS in advance!!!!

2011 Cross Country - Black
2005 Honda Shadow 750 (Traded in on XC)
2007 Sportster 883L (Hers)

Last edited by DMC.Thumper; 05-11-2016 at 05:44 AM.
DMC.Thumper is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 05-11-2016, 09:45 AM
Senior Member
 
rewindguy's Avatar
 
Join Date: Jan 2014
Location: Calgary, Alberta, Canada
Posts: 304
Default

Get into fairing and check all connections - mostly main harness! They can come loose ( not fully clicked in). You may have to cut some of the factory tye wraps as when you check full lock left to full lock right the harness may be under stress and cause the connector to come partially disconnected! Been there, done that!
rocketrod likes this.

2014 Cross Country Tour
Goldrush / Black
rewindguy is offline  
post #3 of 13 (permalink) Old 05-11-2016, 10:06 AM
Senior Member
 
Join Date: May 2013
Location: Left Coast, Canada
Posts: 885
Default

What rewind said...

And when you get them apart look for corrosion or residue that shouldn't be there. Dielectric grease before putting them back together.

Not all those who wander are lost.

2011 Kingpin
53canuck is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 05-12-2016, 05:12 AM Thread Starter
Member
 
DMC.Thumper's Avatar
 
Join Date: Jan 2012
Location: Maine
Posts: 39
Default

Well it's off to the shop for me. I took fairing off, checked every connection and every wire that I could find from the wheel to wheel. I couldn't find anything. Once I got it back to together it's a WHOLE lot worse. The radio completely has a mind of its own. Switch from bands, and stations, and AUX, volume going up and down all on its own......... I hope this doesn't cost me a fortune. A group I ride with has a week long trip to Gettysburg next month.

2011 Cross Country - Black
2005 Honda Shadow 750 (Traded in on XC)
2007 Sportster 883L (Hers)
DMC.Thumper is offline  
post #5 of 13 (permalink) Old 05-27-2016, 11:22 AM Thread Starter
Member
 
DMC.Thumper's Avatar
 
Join Date: Jan 2012
Location: Maine
Posts: 39
Default

Well...after checking everything off to the dealership it went. By the time it got there everything on the dash quit working, but the radio worked fine. They called Victory and ran a bunch of tests. Apparently the instrument cluster is fried. Anyway ever heard of this happening??

2011 Cross Country - Black
2005 Honda Shadow 750 (Traded in on XC)
2007 Sportster 883L (Hers)
DMC.Thumper is offline  
post #6 of 13 (permalink) Old 05-27-2016, 02:09 PM
Senior Member
 
wspollack's Avatar
 
Join Date: Dec 2011
Location: Niskayuna, NY
Posts: 2,069
Default

Quote:
Originally Posted by DMC.Thumper View Post
Well...after checking everything off to the dealership it went. By the time it got there everything on the dash quit working, but the radio worked fine. They called Victory and ran a bunch of tests. Apparently the instrument cluster is fried. Anyway ever heard of this happening??
Nope.

Sorry for your expense, but thanks for posting the outcome. Something to keep in mind if symptoms like that start showing up.

Cheers,

Bill P.

2012 XCT (SOLD) : HeliBars; Centramatics; PC-V; Lloydz air filter; 11" Madstad; Rivco LED mirrors; Doran TPMS; Stebel horn; Motolights; CustomLED trunk flasher; KewlHeel shifter; CycleOps trunk rack; BeadRider seat; Vibranator bar ends; Passenger grab handles; Powerlet outlets; Handlebar RAM mount; RicZ laydown plate; Brukus SaddlebagSecure; 14" flexible antenna; RAM cupholder on trunk; shock Schrader valve relocation.

Gallery: http://www.billanddot.com/victory-xct/
wspollack is offline  
post #7 of 13 (permalink) Old 05-27-2016, 06:33 PM
Senior Member
 
Luciferiad's Avatar
 
Join Date: Apr 2012
Location: Twin Falls, ID
Posts: 1,292
Garage
Default

well, i hate to say it...

your skoot is haunted.

You can call me Billy. Or Luci. But don't call me Shirley.

Mine:
2011 Cross Roads, crimson red
Lloyd'z ATS, IAV, VFC-III. Vic "High Performance" air filter. Ness Big Honkers. Funsies.

Hers
2015 Vegas 8-Ball

My musings:www.billyrulez.wordpress.com
Luciferiad is offline  
post #8 of 13 (permalink) Old 05-27-2016, 07:32 PM
Senior Member
 
DirtyDan's Avatar
 
Join Date: Aug 2013
Location: San Tan Valley, AZ
Posts: 1,501
Default

I have a cluster if your interested. cheap. Off a 2012

2012 Cross Country Champion Trike in process with all the usual mods
2010 cross country, engine change out in process
All sold
2012 XCT,
03/07/12 RG Chopped Bagger
1996 Road King Chopped
2003 FLHTCUI
2003 Big Bear Choppers DA
2000 Chopper Guys rigid EVO
1995 FLHTCU w/Hennigan sidecar
1947 Knuckle
1990 FXRS Convt
1986 Honda CX650C
DirtyDan is offline  
post #9 of 13 (permalink) Old 05-27-2016, 10:18 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

it will take dealer a month to get one

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #10 of 13 (permalink) Old 07-19-2016, 10:26 AM
Member
 
Coast_of_maine's Avatar
 
Join Date: Sep 2012
Posts: 79
Garage
Default

Quote:
Originally Posted by DirtyDan View Post
I have a cluster if your interested. cheap. Off a 2012
Do you still have the cluster? I'm worried mine might have just fried.

2012 Cross Country Tour
Helibars
Madstad Windshield
Coast_of_maine is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome