No Horn? - Victory Forums - Victory Motorcycle Forum
 8Likes
  • 1 Post By RICZ
  • 1 Post By RICZ
  • 1 Post By kodiakwood2
  • 1 Post By djh3
  • 2 Post By JT12
  • 2 Post By JPokerwinski
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 9 (permalink) Old 07-28-2016, 03:29 PM Thread Starter
Junior Member
 
JT12's Avatar
 
Join Date: Aug 2015
Location: Massachusetts
Posts: 25
Garage
Default No Horn?

I have been laid up since December and went to take the bike to get it inspected for the year.... and no Horn. I have no idea what to check first. I haven't changed anything since I last rode in December when the horn worked. do you guys have any ideas i can try to get it working?

2013 Victory Cross Country Tour, Boardwalk Blue
LLoydz ATS +4,1/4 Turn Throttle Ring, O2 sensors unplugged, Vic LED headlight
JT12 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 07-28-2016, 03:47 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,121
Default

First, check the fuse. If good, then remove the horn connectors and hook up a test light to them. If it lights when pressing the button, you'll know the problem is the horn and needs to be replaced. Auto supply stores have disc type horns, some even louder than stock. Or this is a good time to go with a real loud aftermarket type.
JT12 likes this.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #3 of 9 (permalink) Old 07-28-2016, 06:03 PM Thread Starter
Junior Member
 
JT12's Avatar
 
Join Date: Aug 2015
Location: Massachusetts
Posts: 25
Garage
Default

thanks. checked the fuse, its fine. do i check the horn connectors at the horn itself?

2013 Victory Cross Country Tour, Boardwalk Blue
LLoydz ATS +4,1/4 Turn Throttle Ring, O2 sensors unplugged, Vic LED headlight
JT12 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 07-28-2016, 06:10 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,121
Default

Yes sir. That way, you'll know if there is power at the connectors or not. If not, there's a break in the wiring and then you test to see if its the hot wire or the ground. To test for the hot wire, connect test light to the hot wire and the other lead to a bike ground--the battery (-) post if its available. To test for the ground, connect one lead of the test light to a known + source and the other to a ground.
JT12 likes this.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html

Last edited by RICZ; 07-28-2016 at 06:58 PM.
RICZ is offline  
post #5 of 9 (permalink) Old 07-28-2016, 10:02 PM
Senior Member
 
kodiakwood2's Avatar
 
Join Date: Jun 2014
Location: Walland Tennessee
Posts: 471
Garage
Default

My horn stopped working a month ago, turned out to be corroded connectors at the horn. Scrape them clean and apply dielectric grease and good to go
JT12 likes this.

Eastern Tennessee
Current ride
2018 Goldwing tour
Gone but not forgotten...
2014 Cross Country
Black/Chrome
Ultimate seat and driver backrest, Vic passenger backrest, Custom pinstriping by Dave Davies
Lloyds PTS @+5, Lloyds air filter, PC-V, Miller Mufflers, Lloyds Dyno-Tune,
Lloyds quarter turn throttle ring, Victory HID's, RicZ lay down bracket, Barnett "Stealth" clutch cable
kodiakwood2 is offline  
post #6 of 9 (permalink) Old 07-28-2016, 10:49 PM
Lifetime Premium
 
BP6666VR's Avatar
 
Join Date: Dec 2013
Location: World Citizen = A peaceful and peacemaking individual, both in daily life and contacts with others
Posts: 5,979
Default

All good points and help I read above ... Hope OP coinflip can fix his horn ..

Andre
@
TaPaTaLk

JACKPOT 2013 orange MADNESS :-) *HOH-VM1-DR*TachoMeter*PowCom-5*AutoTune*ATS*TorTube & (IAC) & nitro*Swept exhaust*LYNDALL & EBC brakes Front & Rear*Stainless Beads*Fwd Contr 4" *2 x Bad Boy Air Horn*Seven Color Lizard*NGK plugs*Blue Spark Plug Wir*Victory Oil*KN Oil filter*Oil Analysis*Clutch Cover*Kickst Repl Rubb*Invisble-A-Key*L.E.D. Batt. Gauge*Pulsating Brake Light*VictoryHID*Lice Bracket OVAL*BoltKit-Chrome*

Cross Country Tour 2014 [B]
BP6666VR is offline  
post #7 of 9 (permalink) Old 07-29-2016, 03:37 PM
Senior Member
 
djh3's Avatar
 
Join Date: Oct 2015
Location: Central Fl
Posts: 1,095
Default

LOL you all go for test light make sure power at horn etc. Me I probably would have went the hot wire from battery to horn, if it goes beep work my way back. Should get same answer, just different attack angle.
JT12 likes this.

2013 XCT added Jan 2015
pull back bars, passenger arm rests, HID Low beam, Silverstar Ultra headlight high beam,Drag Specialties Pillow Top seat with driver backrest. Glasspack mod Mufflers.
2009 Royal Star Venture-Traded Jan 2016

Trailers are for when it's broke aint it?
djh3 is online now  
post #8 of 9 (permalink) Old 08-12-2016, 10:51 AM Thread Starter
Junior Member
 
JT12's Avatar
 
Join Date: Aug 2015
Location: Massachusetts
Posts: 25
Garage
Default

Thanks for the help guys. It ended up being the horn itself, it wouldn't power when connected directly to the battery. Since I have the dealer warranty, I let them throw a new Horn in there for me.

2013 Victory Cross Country Tour, Boardwalk Blue
LLoydz ATS +4,1/4 Turn Throttle Ring, O2 sensors unplugged, Vic LED headlight
JT12 is offline  
post #9 of 9 (permalink) Old 08-12-2016, 11:32 AM
Lifetime Premium
 
Join Date: Apr 2014
Location: Roanoke , Virginia
Posts: 1,250
Default

Quote:
Originally Posted by jtcoinflip View Post
Thanks for the help guys. It ended up being the horn itself, it wouldn't power when connected directly to the battery. Since I have the dealer warranty, I let them throw a new Horn in there for me.
I would get rid of the road runner horn and put an air horn on it.
toejam and wspollack like this.

Roanoke, Virginia (originally from Ithaca, NY)
USMC - Vietnam
2013 Victory Cross Country Tour
stage 1 Tri-Ovals
Lloydz wheel at +4
Lloydz Air Filter
PCV
Dynoed By Nick at 804 MotorSports
1" tank risers
O2 unplugged
1/4 turn ring
JPokerwinski is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome