HELP!!!!!No High Beams nor High Beam dash indicator - Victory Forums - Victory Motorcycle Forum
 1Likes
  • 1 Post By Triride44
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 (permalink) Old 09-10-2016, 12:41 AM Thread Starter
Senior Member
 
Wrisperj's Avatar
 
Join Date: Nov 2015
Posts: 114
Default HELP!!!!!No High Beams nor High Beam dash indicator

I have a 2015 XCT and recently noticed that I didn't have high beans nor high bean dash indicator. What could be the culprit?

Fort Stewart, GA
2015 XCT
Wrisperj is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-10-2016, 04:31 AM
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

The high beam bulb is burnt out ?

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #3 of 8 (permalink) Old 09-10-2016, 05:26 AM Thread Starter
Senior Member
 
Wrisperj's Avatar
 
Join Date: Nov 2015
Posts: 114
Default

Bulb is fine. Replaced the bulb and results are the same. OBTW I have HID low beam and OEM high if that helps.

Fort Stewart, GA
2015 XCT
Wrisperj is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-10-2016, 05:53 AM
Member
 
Triride44's Avatar
 
Join Date: Apr 2012
Location: South Point, OH
Posts: 98
Default High Beam

Check for power to and from the switch for high beam. Also check the ground for the High Beam bulb.

Black '11 XC, Vance & Hines Hi-Flow muflers,
Lloydz Air Filter & ATS (+4)
Dobeck AFR+ (Gen4)


"People Should Not Be Afraid of Their Governments
Governments Should Be Afraid of Their people".
V for Vendetta.
Triride44 is offline  
post #5 of 8 (permalink) Old 09-10-2016, 06:29 AM
Lifetime Premium
 
doobliss's Avatar
 
Join Date: Aug 2013
Location: Canton, Ohio
Posts: 767
Garage
Default

How's about the fuse box? Any blown ones in there?

'15 Gloss Titanium XC.
WOLO Low Tone Disc Horn
Tri-Oval Slip Ons
Black LED Headlight
Kingpin Metal Fork Guards
Ricz Lay Down Plate
Lloydz Timing Wheel & Throttle Ring
Shinhopples Grip Covers
12" Long Ride Shield
Bad Ace Billet Fork Mounted Air Deflector
Ness Signals; Amber front, Red rear

http://www.pure-gas.org/

"I leave the BUG CARNAGE on my screen , it adds character!"-LILMAGS500
doobliss is offline  
post #6 of 8 (permalink) Old 09-10-2016, 06:33 AM Thread Starter
Senior Member
 
Wrisperj's Avatar
 
Join Date: Nov 2015
Posts: 114
Default

Hadn't checked. Was told low and high were on same fuse.

Fort Stewart, GA
2015 XCT
Wrisperj is offline  
post #7 of 8 (permalink) Old 09-10-2016, 07:03 AM
Member
 
Triride44's Avatar
 
Join Date: Apr 2012
Location: South Point, OH
Posts: 98
Default Not Fuse

Because the low beam is working, the fuse & relay are good. The left handlebar switch has power in on pin 1 from the relay and out to the head light on pins 2 & 3. Low beam on pin 2, and High beam on pin 3.

Black '11 XC, Vance & Hines Hi-Flow muflers,
Lloydz Air Filter & ATS (+4)
Dobeck AFR+ (Gen4)


"People Should Not Be Afraid of Their Governments
Governments Should Be Afraid of Their people".
V for Vendetta.
Triride44 is offline  
post #8 of 8 (permalink) Old 09-10-2016, 07:25 AM
Member
 
Triride44's Avatar
 
Join Date: Apr 2012
Location: South Point, OH
Posts: 98
Default Wiring bug

The fact that the High Beam indicator on the dash doesn't come on, and the low beam works, tells me the switch or wiring is the problem. Electrical wiring problems are sometimes hard to locate. Take your time and think about each step and with some diligence you'll figure it out. Once you find it, should be a easy fix.
BenD likes this.

Black '11 XC, Vance & Hines Hi-Flow muflers,
Lloydz Air Filter & ATS (+4)
Dobeck AFR+ (Gen4)


"People Should Not Be Afraid of Their Governments
Governments Should Be Afraid of Their people".
V for Vendetta.
Triride44 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome