Cruise control issue different than anything I can find anywhere online. - Victory Forums - Victory Motorcycle Forum
 1Likes
  • 1 Post By depot picker
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 (permalink) Old 04-28-2017, 09:25 AM Thread Starter
Tom
Senior Member
 
Tom's Avatar
 
Join Date: Sep 2010
Posts: 108
Default Cruise control issue different than anything I can find anywhere online.

Cruise control issue different than anything I can find anywhere online. My issue is that when I hit the on button for my cruise control light only momentarily flashes and never stays on if I hold cruise and set resume at same time light will come on but in any case nothing ever looks like cruise control turn on and work. Anyone with any ideas would be greatly appreciated.
Tom is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 04-28-2017, 09:27 AM Thread Starter
Tom
Senior Member
 
Tom's Avatar
 
Join Date: Sep 2010
Posts: 108
Default

I apologize my bike is a 2013 victory cross country.
Tom is offline  
post #3 of 8 (permalink) Old 04-28-2017, 10:11 AM
Member
 
Tourider's Avatar
 
Join Date: Oct 2016
Location: Columbus, Ohio
Posts: 40
Garage
Default

When you hit the on button the cruise light on the dash will only come on momentarily, but there is a little red led on the on/off toggle that will stay lit. Only when the cruise is set or resumed will the dash light stay on. It shouldn't be necessary to hold the resume and set down together.


Sent from my iPhone using Tapatalk

2016 Cross Country Tour

Mods:
Victory Passenger Arm Rests
Victory Back Rest
Heel Shifter
Hydraulic Clutch Actuator
Barnett Scorpion Clutch
2" Pull Back Handlebars
Bushtec Hitch
PIAA Driving Lights
WOLO Bad Boy Horn
Kuryakyn Lower Fork Guards

2013 Bushtec Quantum Trailer
Tourider is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 04-28-2017, 10:17 AM
Member
 
Tourider's Avatar
 
Join Date: Oct 2016
Location: Columbus, Ohio
Posts: 40
Garage
Default

Quote:
Originally Posted by Tourider View Post
When you hit the on button the cruise light on the dash will only come on momentarily, but there is a little red led on the on/off toggle that will stay lit. Only when the cruise is set or resumed will the dash light stay on. It shouldn't be necessary to hold the resume and set down together.


Sent from my iPhone using Tapatalk


If you know you are operating it correctly, the switch box could have some moisture in it from a recent washing or rainy ride.


Sent from my iPhone using Tapatalk

2016 Cross Country Tour

Mods:
Victory Passenger Arm Rests
Victory Back Rest
Heel Shifter
Hydraulic Clutch Actuator
Barnett Scorpion Clutch
2" Pull Back Handlebars
Bushtec Hitch
PIAA Driving Lights
WOLO Bad Boy Horn
Kuryakyn Lower Fork Guards

2013 Bushtec Quantum Trailer
Tourider is offline  
post #5 of 8 (permalink) Old 04-28-2017, 11:35 AM Thread Starter
Tom
Senior Member
 
Tom's Avatar
 
Join Date: Sep 2010
Posts: 108
Default

I will definitely look into that thank you for the quick response
Tom is offline  
post #6 of 8 (permalink) Old 04-28-2017, 09:32 PM
Junior Member
 
CrashDavis's Avatar
 
Join Date: Feb 2015
Location: Niceville, FL
Posts: 13
Default

What Tourider said (post #3). I have also had problems when in a monsoon. When my bikes gets soaked (washing doesn't provide enough water but raining cats and dogs does) my cruise control and clutch safety switch quits working until they dry out.

'13 XCT - Bronze
CrashDavis is offline  
post #7 of 8 (permalink) Old 04-28-2017, 09:39 PM
Lifetime Premium
 
Join Date: Dec 2009
Location: Chattanooga, TN
Posts: 1,846
Default

Search for a thread about Cross Country Intermittent Cruise Control.

Very likely the throttle cable switch. It's tucked under the right side of the tank. It can be seen with the bike on the side stand. You'll give yourself more room to work by turning the front wheel fully to the left. The switch has two wires going into it. Pull both wires, tape them off and try your cruise control again. What that switch does is disengage the cruise control when you manually turn the throttle closed. The cruise will still disengage with the clutch lever, the front brake lever or the rear brake lever. It's a $20 switch, mine went out last year and I see no reason to replace it.

The switch is a known item that's prone to failure. But the work around is simple and effective. My throttle cables are adjusted properly, but it's always good practice to ensure yours are adjusted correctly as well.

Keep us posted.

All the best,

Mark


www.bikersforchrist.org

The Bible: Read, Apply, Repeat

"That's a beautiful Victory!"
"Thank you."
"Who makes it?"
"No one."

Who turns Victory into defeat? Polaris Industries, that's who.

2012 Pearl White CCT. Lloyds DR cams, Timing Wheel (+4), Air Filter, 1/4 Turn Throttle Ring, PCV, Tri Oval mufflers, Dyno Tune from Rylan Vos - The Vic Shop: 112/113. Bad Ace Billet tank lifts and Raging Cajun Medium Low & Throaty mufflers added well after the Dyno run.

Last edited by Chattanooga Mark; 04-29-2017 at 08:18 PM.
Chattanooga Mark is offline  
post #8 of 8 (permalink) Old 04-29-2017, 07:33 AM
Lifetime Premium
 
depot picker's Avatar
 
Join Date: Oct 2011
Location: Somewhere. Wherever.
Posts: 2,305
Default

The cable to that switch being out of adjustment will do that.
Chattanooga Mark likes this.
depot picker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome