Speedometer in Auto turn signal cancel stopped working - Victory Forums - Victory Motorcycle Forum
 2Likes
  • 1 Post By BBob
  • 1 Post By TOWNSENDRO
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 8 (permalink) Old 09-19-2019, 12:15 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Default Speedometer in Auto turn signal cancel stopped working

I clean the turn signal connector, and I ran the speed sensor and cruise control checks. Got no signal from the speed sensor check, and fails on throttle and and speed sensor from the cruise control check. I also cleaned the speed sensor connector. I'm prepared to change the speed sensor, but is there anything else I should check? Help please!!!
TOWNSENDRO is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-19-2019, 03:03 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,924
Garage
Default

It makes it so much easier when folks just put what they ride in their signature... Year and Model will do.
TNXR likes this.
BBob is offline  
post #3 of 8 (permalink) Old 09-19-2019, 07:11 PM
Senior Member
 
Join Date: May 2018
Location: Indianapolis
Posts: 1,134
Default

Quote:
Originally Posted by BBob View Post
It makes it so much easier when folks just put what they ride in their signature... Year and Model will do.
Being in the cross bike forum section one would bet it's a cross bike.
Pic in intro thread is a cross country.
IndyVictory is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-19-2019, 08:07 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,924
Garage
BBob is offline  
post #5 of 8 (permalink) Old 09-19-2019, 08:12 PM
Senior Member
 
Join Date: May 2018
Location: Indianapolis
Posts: 1,134
Default

Turn signal auto cancel uses speed sensor. If you're below some slow speed it will blink forever. If you're moving fast enough it cuts off.

If your speedometer is also broken as you say then I'd go for replacing the speed sensor. IF that doesn't cure it you have a spare part for future backup use.
IndyVictory is offline  
post #6 of 8 (permalink) Old 09-19-2019, 09:23 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Default

Sorry it's a 2011 Cross country. Thanks I'll swap the sensor.
TOWNSENDRO is offline  
post #7 of 8 (permalink) Old 09-24-2019, 08:05 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 6
Default

I swapped the speed sensor now everything works. Thanks for the advice!
broggyr likes this.
TOWNSENDRO is offline  
post #8 of 8 (permalink) Old 09-24-2019, 08:15 AM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,368
Garage
Default

Glad you found the issue and were able to get it fixed.



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +3, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome