Radio Condensation CCT 2012 - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 12-04-2013, 05:47 AM Thread Starter
Junior Member
 
Join Date: Oct 2012
Location: Australia
Posts: 16
Default Radio Condensation CCT 2012

I have had condensation in the Radio LED face plate a couple of times after washing the bike.

My concerns are that this might cause audio faliure down the track as ANY internal moisture cant be good.


I have read previously others have had the condensation issue, can you tell me..


Has it been replaced under warranty?

Did Victory insist on pulling the headset out and have it sent to head office for inspection, prior to replacement?






Thanks for any feedback

Last edited by Savage; 12-07-2013 at 09:59 PM.
Savage is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 12-04-2013, 07:13 AM
Senior Member
 
Lostintexas's Avatar
 
Join Date: May 2012
Location: East Texas
Posts: 784
Default

If you are still under warranty, get it replaced. No excuse for the build on these bikes. XCT electrics seem fragile. It seems the folks that made them aren't privvy to the fact they will actually be ridden in other than 65-85 degree, sunny day conditions.
Things like this are why mine is very close to being traded on something less needy. Sad, it is a great rider, but has issues in the electrical areas.

Some people go their whole life wondering if they made a difference, Marines don't have that problem.~ Ronald Reagan

2012 XCT, AFR+ Gen 4, Lloydz air filter. I don't equate noise with power.
I ride with the Force.
Lostintexas is offline  
post #3 of 4 (permalink) Old 12-07-2013, 03:06 PM
Member
 
Join Date: Mar 2011
Location: Rothschild, WI.
Posts: 55
Default

My 2013 XCT did it too. I had the radio unit replaced under warranty at no cost. The steaming of the glass will eventually leave a stain that will be noticable.

Red 2013 Cross Country Tour
Rothschild, Wi.
jackthebiker is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 12-08-2013, 09:57 AM
Senior Member
 
Join Date: Aug 2011
Location: SE Michigan
Posts: 520
Default

My 2010 does it occasionally if you put the hose to it. It dries out on its own, never had a problem in 30k miles.
Bikendad is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome