rain issues? - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 11 (permalink) Old 06-20-2011, 04:47 PM Thread Starter
Member
 
Join Date: Mar 2011
Location: Mentor, Ohio
Posts: 37
Default rain issues?

Was caught out in the rain yesterday and noticed that when I had clutched in the hazards came on....anyone else have this issue?
fferic is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-20-2011, 08:18 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,061
Default

Quote:
Originally Posted by fferic View Post
Was caught out in the rain yesterday and noticed that when I had clutched in the hazards came on....anyone else have this issue?
HUH? What do you mean by "clutched in?" and what hazards are you speaking of? If you are pulling the clutch lever in while attempting to negotiate hazards in the wet - that's wrong. Motorcycles operate best under power. But that power needs to be greatly modulated in the wet.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #3 of 11 (permalink) Old 06-20-2011, 08:30 PM Thread Starter
Member
 
Join Date: Mar 2011
Location: Mentor, Ohio
Posts: 37
Default .

When I was coming to a stop I would pull in the clutch and the 4 wayy or hazard lights came oon
fferic is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 06-20-2011, 08:36 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,061
Default

Now I get it. I can't help you with that problem, sorry. I often hit the hazard light switch when wanting to flip the high beams on. Guess I need to get my synapses wired better.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #5 of 11 (permalink) Old 06-21-2011, 03:07 PM Thread Starter
Member
 
Join Date: Mar 2011
Location: Mentor, Ohio
Posts: 37
Default ...

Anyone else have this issue
fferic is offline  
post #6 of 11 (permalink) Old 06-21-2011, 04:03 PM
Junior Member
 
Join Date: Dec 2010
Posts: 8
Default

I was riding in the rain today myself and noticed my hazards were on, I thought I just bumped the switch. I'll see if this is a pattern. I have 2011 Cross Roads.
shewstring is offline  
post #7 of 11 (permalink) Old 06-21-2011, 07:01 PM
Member
 
BigRedXerII's Avatar
 
Join Date: Oct 2010
Location: Southern Indiana
Posts: 84
Default

Been out the rain a few times , a couple of light and a few steady rains. No heavy rains yet.

It hasn't happened yet but I will keep my eye out for it.

'68 5hp Tote Goat minibike - My 1st Ride
'82 GS550L Suzuki - long gone
'91 1100 Shadow - gone
'91 900RR - gone
'02 1800 VTX Retro - Looking for a new home
'11 Cross Country - new ride looking new for twisties


"Its about the Journey and the Friends we make."
BigRedXerII is offline  
post #8 of 11 (permalink) Old 06-21-2011, 08:32 PM
Senior Member
 
gulliverstoe's Avatar
 
Join Date: Jun 2010
Posts: 289
Default

howdy

i got aught out a bit last fall...ended up with a couple of hundred in the rain....some hard.like in go 30...some not so much like in hack it at 60 ... but all moving highway other than a stop for leather...no issues other than the rain itself......perhaps the focus is the stopping and letting it drip in?

Tucson
2010 XCountry
gulliverstoe is offline  
post #9 of 11 (permalink) Old 06-22-2011, 07:31 AM
Senior Member
 
wesdalton's Avatar
 
Join Date: May 2010
Location: Utah
Posts: 679
Default

The same thing happened to me when I washed my XC at a car wash. I took it to my dealer, they pulled apart the switch box assembly on the handle bars and lubed all of the connections with dielectric grease. I have not had any problems since with that, but my ipod connection (outside of the saddlebag) started acting up. I have started using the lube on all of the electric plug ins. I am disappointed with vic having that kind of a problem with wiring plugs. They have been building (polaris) vehicles designed for severe weather use from day one. You would think they wouldn't have that kind of problem.

2010 X C
wesdalton is offline  
post #10 of 11 (permalink) Old 06-22-2011, 08:04 AM
Senior Member
 
ALStensby's Avatar
 
Join Date: Apr 2011
Location: Brooklyn Park, MN
Posts: 693
Default

No issues on my end and about half the riding I've done this year has been in the rain since buying the bike. Ugh. lol I'll keep an eye out of it.

Adam
2011 Victory Cross Roads - His
2014 Indian Chief 'Springfield' - Hers
2013 Honda CB500F
ALStensby is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome