tr17047 - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 07-24-2011, 09:17 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Posts: 28
Default 2011 cross country wont crank over battery is good?

2011 cross country wont crank, acts like battey is low but battery checks out good, any ideas ?

Last edited by tr17047; 07-24-2011 at 09:24 PM. Reason: NEED TO CHANGE POST
tr17047 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-24-2011, 09:21 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Hi and welcome to the forum. What does the battery voltage show while you're trying to crank it?

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #3 of 5 (permalink) Old 07-24-2011, 09:26 PM Thread Starter
Junior Member
 
Join Date: Mar 2011
Posts: 28
Default

I dont know,havent checked that ?
tr17047 is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 07-24-2011, 09:39 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by tr17047 View Post
I dont know,havent checked that ?
You might want to check it. Battery shows its true colors under load. If it's around 12 Volts while you're trying to start it, then you can eliminate the battery as the culprit. It might be the easiest suspect to eliminate off the list. Fuel pump would be my second suspect, but I wouldn't mess with it until you can confirm the battery's good under load. Test it, and let us know.

Speaking of fuel pump, when you turn on the ignition, do you hear the fuel pump priming?

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #5 of 5 (permalink) Old 07-25-2011, 11:47 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

Do you have headlight? Does it dim when you push the button?
If it doesn't dim I mean very slightly then you might have loose connections. Is your kill switch on?
If you have good battery check connections at starter relay its a gold color round piece behind the battery.
visionjohnny is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome