Clicking when turning off bike. - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 14 (permalink) Old 02-17-2014, 09:58 AM Thread Starter
Senior Member
 
Join Date: Oct 2013
Location: Portland, OR
Posts: 192
Default Clicking when turning off bike.

Hello all!

Have a 2010 XCT and I'm getting a clicking noise on the right side near the front sometimes when I turn off the bike. Anyone know what this could be?
Wyckedjester is offline  
Sponsored Links
Advertisement
 
post #2 of 14 (permalink) Old 02-17-2014, 11:16 AM
Senior Member
 
Goatlocker95's Avatar
 
Join Date: Apr 2011
Location: Maryland
Posts: 851
Default

I get clicking from my heated pipes cooling off.

2014 Indian Chieftain
Goatlocker95 is offline  
post #3 of 14 (permalink) Old 02-17-2014, 11:42 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,938
Default

its normal fuel pump

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
post #4 of 14 (permalink) Old 02-17-2014, 01:14 PM
Senior Member
 
Join Date: Sep 2013
Location: Cottage Grove, Minnesota
Posts: 107
Default

Quote:
Originally Posted by Wyckedjester View Post
Hello all!

Have a 2010 XCT and I'm getting a clicking noise on the right side near the front sometimes when I turn off the bike. Anyone know what this could be?
I have a 2013 XC and mine does exactly the same thinking. Was wondering what it was as well.

2013 Cross Country - Antifreeze Green
Cottage Grove, Minnesota

VM1-DR Cams
Power Commander
Lloydz air filter
Timing gear
1/4 throttle
Dyno tune from the Vic Shop

107.44 HP
108.03 Torque
MN Victory is offline  
post #5 of 14 (permalink) Old 02-17-2014, 02:02 PM
Senior Member
 
Goatlocker95's Avatar
 
Join Date: Apr 2011
Location: Maryland
Posts: 851
Default

Quote:
Originally Posted by visionjohnny View Post
its normal fuel pump
The fuel pump running happens when you turn the bike ON not OFF

2014 Indian Chieftain
Goatlocker95 is offline  
post #6 of 14 (permalink) Old 02-17-2014, 02:22 PM
Senior Member
 
Encmerk's Avatar
 
Join Date: Jan 2014
Location: Havelock, NC
Posts: 173
Garage
Default

Does it sound like this? http://s1260.photobucket.com/user/En...lpump.mp4.html If so it is normal. The pressure relief valve takes pressure off rails and backside of pump when not running.EDIT the noise is not a pressure relief, it is the IAC stepper motors. Thanks Vicbuilder!

Master Sergeant, USMC Retired

2002 HD Sportster 1200 Custom -sold
2013 XCT Boardwalk Blue picked up 1/21/2014
Vance and Hines hi output slip-ons
Lloydz hi-flow air filter
PCV w/AT
Lloydz ATS @ +4
CrossRoads HID's Hi and Low
Havelock, NC

Last edited by Encmerk; 02-17-2014 at 02:35 PM.
Encmerk is offline  
post #7 of 14 (permalink) Old 02-17-2014, 02:29 PM
Senior Member
 
Vicbuilder's Avatar
 
Join Date: Jun 2011
Location: Central Iowa
Posts: 403
Default

Actually, it's the IAC stepper motors. Completely normal to hear this.

http://www.nmbtc.com/nmb-component-a...ontrol-valves/

Rylan Vos
The Vic Shop, Inc
(515)-339-4313
Vicbuilder is offline  
post #8 of 14 (permalink) Old 02-17-2014, 02:34 PM
Senior Member
 
Encmerk's Avatar
 
Join Date: Jan 2014
Location: Havelock, NC
Posts: 173
Garage
Default

I defer to your superior knowledge on the subject....

Master Sergeant, USMC Retired

2002 HD Sportster 1200 Custom -sold
2013 XCT Boardwalk Blue picked up 1/21/2014
Vance and Hines hi output slip-ons
Lloydz hi-flow air filter
PCV w/AT
Lloydz ATS @ +4
CrossRoads HID's Hi and Low
Havelock, NC
Encmerk is offline  
post #9 of 14 (permalink) Old 02-17-2014, 02:53 PM
Lifetime Premium
 
Krisd's Avatar
 
Join Date: Dec 2013
Location: Sydney, Australia
Posts: 1,367
Default

Got any dolphins in your trunk?


2012 Hammer S
Freedom Performance pipes now wrapped, PCV, Loyds air filter, ATS, Loyds Cams and 1/4 Turn Throttle adj, Progressive rear shock
300mm rear and 23" front
Krisd is offline  
post #10 of 14 (permalink) Old 02-17-2014, 03:09 PM
Senior Member
 
TheBigBK's Avatar
 
Join Date: Feb 2013
Location: Halifax, NS
Posts: 530
Default

I was thrown by the noise at first too. I must have been so enthralled with the ride, the looks, the everything else when i first got her home because I didn't notice the sound the first few times I rode her. So I thought it was something that developed. I felt kinda silly asking about it at the shop...wish I had just asked here....so faceless so anonymous, no fear.

Anyone know why it burns when I pee?

theBIGbk
2013 Judge
Long live the oval
TheBigBK is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome