oil idiot light stays on after bike is turned off - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 17 (permalink) Old 04-18-2014, 08:11 PM Thread Starter
Senior Member
 
bdbaggr's Avatar
 
Join Date: Mar 2014
Location: santa cruz mountains
Posts: 263
Garage
Default oil idiot light stays on after bike is turned off

i have 600 miles on new 2014 xc and i just noticed the oil light stayed on after i removed the key for a second or two... right after my 500 mile service. i checked oil, fine, then called shop and mechanic told me that happens sometimes on these bikes... any of you guys have this happen? it doesnt do it all the time intermitant. thanks
bdbaggr is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 04-18-2014, 08:19 PM
Senior Member
 
Join Date: Mar 2014
Location: duson,louisiana
Posts: 160
Default

Even if it happens sometimes it should be fixed under warenty.

2013 cross country tour stock for now
whiskeydave is offline  
post #3 of 17 (permalink) Old 04-18-2014, 08:19 PM
Senior Member
 
rlaws797's Avatar
 
Join Date: Oct 2013
Location: Richmond, TX
Posts: 152
Default

Mine does it too. Has since day 1. I've been told it's normal-

Ride safe!


Sent from Motorcycle.com Free App

Houston, TX

2015 XC Suede Black w/ Red Pinstripes
rlaws797 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 04-18-2014, 08:35 PM Thread Starter
Senior Member
 
bdbaggr's Avatar
 
Join Date: Mar 2014
Location: santa cruz mountains
Posts: 263
Garage
Default

Quote:
Originally Posted by rlaws797 View Post
Mine does it too. Has since day 1. I've been told it's normal-

Ride safe!


Sent from Motorcycle.com Free App
does it always do it? or intermittently?
bdbaggr is offline  
post #5 of 17 (permalink) Old 04-18-2014, 08:46 PM
Senior Member
 
rlaws797's Avatar
 
Join Date: Oct 2013
Location: Richmond, TX
Posts: 152
Default

Best I remember, it does it every time.

I don't think it's something to worry about. I forget, but I recall reading somewhere it was normal.

Maybe others will chime in and concur -


Sent from Motorcycle.com Free App

Houston, TX

2015 XC Suede Black w/ Red Pinstripes
rlaws797 is offline  
post #6 of 17 (permalink) Old 04-18-2014, 09:29 PM
Senior Member
 
Join Date: Oct 2009
Location: Bay Arkansas
Posts: 269
Default

Quote:
Originally Posted by rlaws797 View Post
Best I remember, it does it every time.



Maybe others will chime in and concur -


Sent from Motorcycle.com Free App

Mine does it too.. I'm pretty sure not all the time though but most of the time for sure..!


Sent from Motorcycle.com Free App

Victorypotamus
Milesx is offline  
post #7 of 17 (permalink) Old 04-18-2014, 10:01 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,928
Default

pull wire off sending unit and clean it. The sending unit is right behind the end of the kickstand if it was up.

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #8 of 17 (permalink) Old 04-18-2014, 10:51 PM
Junior Member
 
Join Date: Aug 2013
Location: Oklahoma
Posts: 12
Default

I have a 2012 XC and it does the same thing and has since it was brand new.
oklahomamaskedman is offline  
post #9 of 17 (permalink) Old 04-19-2014, 04:24 AM
Lifetime Premium
 
GatorJoe's Avatar
 
Join Date: Oct 2012
Location: Lake City, FL
Posts: 1,018
Garage
Default

Quote:
Originally Posted by oklahomamaskedman View Post
I have a 2012 XC and it does the same thing and has since it was brand new.
2012 XC and has never done it ..

2017 Indian Chieftain Dark Horse/2005 Dyna Super Glide
GatorJoe is offline  
post #10 of 17 (permalink) Old 04-19-2014, 06:10 AM
Lifetime Premium
 
half_crazy's Avatar
 
Join Date: Sep 2011
Location: Southern Maryland
Posts: 4,817
Default

Quote:
Originally Posted by GatorJoe View Post
2012 XC and has never done it ..
I learned a long time ago... no matter what brand of motorcycle you have... almost anything you ask the dealer about, from a vibration/noise to grabby clutch/shifting issue, the answer will be "They all do that".

2006 Victory Kingpin
Lloydz 116" Stroker/Big Bore, .495 Cams, Torque Tubes Airbox,
RPW Thor Pipe, Lloydz ECU Flash, PC-III, PTS (-2), Rivera
Primo Clutch Spring, 31 Tooth Pulley w/Buell Belt.
half_crazy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome