LCD display problem - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 15 (permalink) Old 04-25-2014, 01:21 PM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default LCD display problem

I have a 2010 XR and love it!
Except for the speedo with LCD display......
I have ALREADY had my whole speedo replaced due to the LCD display going bad.....it is happening again!!!!! WTF!
Anyone else had issues with theirs???


Sent from Motorcycle.com Free App

2010 Cross Roads
Vic HP air filter
Stage 1
D&D slash cut mufflers
Lloyd's Adjustable Timing Wheel @ 4
Kuryakyn Engine Guard Driving lights
Sabertooth auxiliary tail lights
7jurock custom WS with vent
Cee Bailey lowers
Ness Tear Drop mirrors
45caldan is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 04-25-2014, 01:25 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by 45caldan View Post
I have a 2010 XR and love it!
Except for the speedo with LCD display......
I have ALREADY had my whole speedo replaced due to the LCD display going bad.....it is happening again!!!!! WTF!
Anyone else had issues with theirs???
Did not have a problem with mine. How is it "going bad?" What is it doing (or not doing)?

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #3 of 15 (permalink) Old 04-25-2014, 01:32 PM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Question

Quote:
Originally Posted by CrossRoads View Post
Did not have a problem with mine. How is it "going bad?" What is it doing (or not doing)?
Simply it gets lighter to where you can't see the letters or digits.
So I can't even see the miles, fuel, clock, etc!!!
45caldan is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 04-25-2014, 01:33 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by 45caldan View Post
Simply it gets lighter to where you can't see the letters or digits.
So I can't even see the miles, fuel, clock, etc!!!
Is that the only electrical gremlin on the bike? Everything else works fine? How long did it work fine (1st speedo and 2nd speedo).

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #5 of 15 (permalink) Old 04-25-2014, 01:39 PM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default

Quote:
Originally Posted by CrossRoads View Post
Is that the only electrical gremlin on the bike? Everything else works fine? How long did it work fine (1st speedo and 2nd speedo).
Yup that's been my ONLY issue.
The first one happened at around 12800 miles.
Second one at 9000 (on new odometer).

Last edited by 45caldan; 09-23-2014 at 10:25 AM.
45caldan is offline  
post #6 of 15 (permalink) Old 04-27-2014, 06:59 PM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default

Really, no one?
It just seems strange this happened not only once but twice now.
From my perspective, it seems like this would be a common problem.....
45caldan is offline  
post #7 of 15 (permalink) Old 04-30-2014, 06:39 AM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default

Well took her in yesterday.
They'll look at it, have to call in for the warranty, order the new speedo and replace it AGAIN.
Service guy said I am the only one that they've seen this happen to and now TWICE!
I'm gonna take a big hit on resale because of all this...
45caldan is offline  
post #8 of 15 (permalink) Old 09-23-2014, 08:37 AM
Member
 
Join Date: May 2010
Posts: 58
Default Same for me

Quote:
Originally Posted by 45caldan View Post
Really, no one?
It just seems strange this happened not only once but twice now.
From my perspective, it seems like this would be a common problem.....
You're not the only one. I've had one replaced already, and just this morning the second one did the exact same thing. Now I can't read anything on the LCD display.

____________________________
2010 Cross Roads
lhmathys is offline  
post #9 of 15 (permalink) Old 09-23-2014, 09:35 AM Thread Starter
Senior Member
 
45caldan's Avatar
 
Join Date: May 2012
Location: Lakeland, FL
Posts: 216
Default

Quote:
Originally Posted by lhmathys View Post
You're not the only one. I've had one replaced already, and just this morning the second one did the exact same thing. Now I can't read anything on the LCD display.
So this HAS happened to someone else!
My dealer said to try and keep the Bike out of the elements.....
It's garaged when I'm not riding and I always look for a shady spot to park.....
Guess I need a bubble....

2010 Cross Roads
Vic HP air filter
Stage 1
D&D slash cut mufflers
Lloyd's Adjustable Timing Wheel @ 4
Kuryakyn Engine Guard Driving lights
Sabertooth auxiliary tail lights
7jurock custom WS with vent
Cee Bailey lowers
Ness Tear Drop mirrors

Last edited by 45caldan; 09-23-2014 at 10:24 AM.
45caldan is offline  
post #10 of 15 (permalink) Old 09-23-2014, 09:56 AM
Senior Member
 
Rebel Biker's Avatar
 
Join Date: Aug 2012
Location: West Fork, Arkansas
Posts: 1,533
Garage
Default

Try to keep it out of the elements???? I'd tell my dealer right then and there that there aint a chance of it. They'll just have to make sure my bike can stand up to the elements. (It's basically what I told my dealer when my electronic cruise control module fried on my ole KP). It's not like we bought some cheap bike that costs $6k new. 'cmon, they are designed to be able to hold up to the elements and if it fails, its on them to resolve it so it can. I ride in all weather and my expensive bike better be able to ride in all weather too. They need to find the permanent solution for you, bottom line.

https://www.youtube.com/watch?v=KOZw...ature=youtu.be

2014 Victory Cross Country Tour - Two Tone Sonic Blue and Silver

PCV 6,500 rev limit, Lloydz VM1-DR Cams, Lloydz Hi Flow Filter, Atom Bomb exhaust, Lloydz ATS +4, Lloydz 1/4 Throttle. 111 HP / 116 TQ
2012 Victory Kingpin - Traded in on XCT

2007 Honda Shadow Aero 750 - Traded in on KP
Rebel Biker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome