bike died yesterday - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 7 (permalink) Old 04-25-2011, 12:57 PM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default bike died yesterday

was out on a ride with 5 others and was in front,coming through mid wales,I rounded a blind sharp narrow bend at the start of a steep climb when the bike suddenly stopped. Iwas stranded in middle of road holding bike on brake the other riders and a mercedes estate car just managed to go around me,it was very close. Switched ignition on and off afew times and had to find neutral on a steep hill to start the bike again. Pulled over at a layby and found battery terminals had worked loose,tightened them up and the bike ran home ok. I was quite shaken by this and now think the "starts only in neutral" idea not so good,the time it took to get the bike out of a hazardous situation was critical,but I will check these terminals every month from now.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-25-2011, 01:28 PM
Senior Member
 
Join Date: Sep 2010
Posts: 567
Default

Quote:
Originally Posted by goon View Post
was out on a ride with 5 others and was in front,coming through mid wales,I rounded a blind sharp narrow bend at the start of a steep climb when the bike suddenly stopped. Iwas stranded in middle of road holding bike on brake the other riders and a mercedes estate car just managed to go around me,it was very close. Switched ignition on and off afew times and had to find neutral on a steep hill to start the bike again. Pulled over at a layby and found battery terminals had worked loose,tightened them up and the bike ran home ok. I was quite shaken by this and now think the "starts only in neutral" idea not so good,the time it took to get the bike out of a hazardous situation was critical,but I will check these terminals every month from now.
It is called "preventive maintenance" ...a drop or two of locktight wouldn't hurt either (blue formula)

Northern NY...2010 Vegas, S&S Performance Intake, PCV with Auto tume module , Bassani 2 into 1 Short pipes, Kewl metal accessories, Cycle-ops accessories...:crzy:
Paul M is offline  
post #3 of 7 (permalink) Old 04-25-2011, 09:49 PM
Senior Member
 
Join Date: Mar 2011
Posts: 307
Default

dunno if you have this or not but on my 2007 hammer all of a sudden i couldnt start it in gear turns out there is a plug connector right at the clutch lever that wasnt connected all the way i pushed it in till i heard a click then i could start the bike in gear.Might want to have a look
hammer316 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 04-26-2011, 08:20 AM
Senior Member
 
Join Date: Sep 2010
Posts: 567
Default

Quote:
Originally Posted by hammer316 View Post
dunno if you have this or not but on my 2007 hammer all of a sudden i couldnt start it in gear turns out there is a plug connector right at the clutch lever that wasnt connected all the way i pushed it in till i heard a click then i could start the bike in gear.Might want to have a look
Read the post Bro...He stated his battery terminal connector came loose....

Northern NY...2010 Vegas, S&S Performance Intake, PCV with Auto tume module , Bassani 2 into 1 Short pipes, Kewl metal accessories, Cycle-ops accessories...:crzy:
Paul M is offline  
post #5 of 7 (permalink) Old 04-26-2011, 11:10 AM
Senior Member
 
Join Date: Mar 2011
Posts: 307
Default

Me bad !sorry Man
hammer316 is offline  
post #6 of 7 (permalink) Old 04-26-2011, 01:26 PM
Senior Member
 
Join Date: Sep 2010
Posts: 567
Default

Quote:
Originally Posted by hammer316 View Post
Me bad !sorry Man
Hey, don't apologize....Just pointing it out....that's all.....Not an issue in my book....(not my bike...LOL)

Northern NY...2010 Vegas, S&S Performance Intake, PCV with Auto tume module , Bassani 2 into 1 Short pipes, Kewl metal accessories, Cycle-ops accessories...:crzy:
Paul M is offline  
post #7 of 7 (permalink) Old 04-27-2011, 10:43 AM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default

had to adjust the microswitch on clutch,now starts in gear fine.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome