cumming dealer - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 5 (permalink) Old 02-09-2012, 02:51 PM Thread Starter
Senior Member
 
ronfox's Avatar
 
Join Date: Jun 2009
Location: columbus ga,
Posts: 301
Default cumming dealer

folks ive seen some bad comits about freedom in cumming ga, checked and saw more bad reports on kennesaw ga, this makes me think about something.
when i bought my xct out of crate & after prep, i went over with sales guy, i started and went for ride the red engine light came on for a very short time and went off, i was told that it was normul when you start up its preshure build up. it only happens during start up then never. is this bull or what,

SUPPORT YOUR LOCAL ABATE !!

KNIGHTS OF SOLOMON MC
HARRIS COUNTY, GA,

custom 1999 bobber
2012 cross country tour
sunset red
D&D slip on
16 inch ness apes
performance up grade ( cams, )
painted red inside fairin to match
(mods to come )
Its not really what you ride, but that you ride!
ronfox is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-09-2012, 04:13 PM
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,181
Default

Do you jump on and ride or do you let it warm up the back cylinder first? Oil check every day on a new motor, I would document the check of the oil and the red light when it comes on. Are you accelerating hard when it comes on? Are you following the proper guide lines of breaking in your new motor? These are things on a warranty issues when they arise. If the dealer goes under or you take it some where else to get it looked at. I would log every thing..

2012 Fireball Jackpot
gibson is offline  
post #3 of 5 (permalink) Old 02-09-2012, 07:47 PM Thread Starter
Senior Member
 
ronfox's Avatar
 
Join Date: Jun 2009
Location: columbus ga,
Posts: 301
Default

when you start up it comes on for a few, goes off comes on for a short, then gos of and stays off. when you ride after warmed up never comes on, only after siting 4 to 6 hours. and yes i let warm up and breake in correct.
thanks

SUPPORT YOUR LOCAL ABATE !!

KNIGHTS OF SOLOMON MC
HARRIS COUNTY, GA,

custom 1999 bobber
2012 cross country tour
sunset red
D&D slip on
16 inch ness apes
performance up grade ( cams, )
painted red inside fairin to match
(mods to come )
Its not really what you ride, but that you ride!
ronfox is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-09-2012, 08:22 PM
Senior Member
 
ammo_umb's Avatar
 
Join Date: Sep 2010
Location: Utah
Posts: 2,699
Default

I have over 12000 on my 11 XR and have started it 100's of times. The lights in the guages come on when I turn on the ignition then go off when I start it. None of them stay on so yours sounds a little wonky. I would make sure the oil is at the right level; too low and the light will come on but if it's anything like my V-Star the light may also come on if it's too high.

Retired USAF, IYAAYAS!

2008 V-Star 1100 Custom Bobber project

2011 Crimson XR with Forged Highway Bars / Hard Bags / Passenger Backrest, Ness parts including Smooth Layback Plate Frame/Mount / Rad 3 Mirror / deep cut grips / drivers floorboards /shifter peg / brake peg / passenger pegs. Witchdoctor black rack, Lloydz filter / timing wheel / VFC III, 7Jurock windshield, Drag Specialties seat.
ammo_umb is offline  
post #5 of 5 (permalink) Old 02-10-2012, 12:17 AM
Senior Member
 
ashmostro's Avatar
 
Join Date: Apr 2011
Posts: 442
Default

Quote:
Originally Posted by ammo_umb View Post
I have over 12000 on my 11 XR and have started it 100's of times. The lights in the guages come on when I turn on the ignition then go off when I start it. None of them stay on so yours sounds a little wonky. I would make sure the oil is at the right level; too low and the light will come on but if it's anything like my V-Star the light may also come on if it's too high.


Agreed. Check oil level first. If ok, consider an oil change using standard vic oil- it's possible the dealer put the wrong weight in.

How long have you had the bike and whats the mileage?

2011 Victory Kingpin 8-Ball
Tach / Dual front discs with Vesrah JL pads / Penske shock / S&S Intake / PCV & autotune / RPW Thor exhaust with homemade custom baffle / Tsukayu leather "Strong" bags / Avon Cobra *Radials* / Ness Vegas Peg Conversion / Ness Vegas driver's seat / Custom T-Apes from BR Custom Cycles
ashmostro is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome