SPEEDOMETER & ODOMETER Stopped working - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 08-14-2014, 08:21 PM Thread Starter
New Member
 
Join Date: Aug 2014
Posts: 1
Question SPEEDOMETER & ODOMETER Stopped working

I have a 2003 Victory V92TC and the speedometer & odometer just quit working. The odometer is still reading the digital miles when it stopped, 24,502 but it's not rolling. Check engine light is on & tachometer is still reading correctly. Is this a minor problem I can fix myself or is this something I need to take to a dealer?? I don't want to get a speeding ticket on my bike....

I appreciate any input.
Charles Smith
Willis, TX 77318
oceancowboy82 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-15-2014, 10:55 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,949
Default

Put a wrench on your battery bolts and see if there tight. How old is the battery. Have you checked the fuses.
Look in headlight housing for loose connection

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 4 (permalink) Old 08-20-2014, 07:04 AM
Member
 
streetdoc432's Avatar
 
Join Date: Mar 2014
Location: Memphis, TN
Posts: 71
Default

Replace your speedometer pickup. 100$ part, 10 minutes to replace yourself.


Sent from Motorcycle.com Free App

2010 Cross Country Tour clone
Midnight Cherry
Klock Werks windshield, Madstad brackets,
116 ci, timing wheel, intake, cams, PC-V, AIV,
Nascar6 pipes, Polk 6.5, RF PBR300x4 amp
streetdoc432 is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-20-2014, 04:14 PM
Senior Member
 
Tims_04V92TC's Avatar
 
Join Date: Oct 2011
Location: Chesapeake Va
Posts: 1,499
Garage
Default

Look behind the drive pulley and see if the pickup came loose and that the connection is clean and tight. While your down there inspect for red dust which is a sgn your drive pulley nut may have broken torque. Not uncommon.

2011 White Vision - Nuvi 550, Lowers, Lloydz 2nd filter, Vic perf filter, CB/Icom, 96 Brake LED's, Clear Signal lens/Switchbacks, VIC Hwy Pegs, Stebel Horn, 7Jurock 15" Shield, PCV, Lloyd ATS and Variable intake, Ness honkers

2004 V92 TC - S1 flash, level 1 slip-on, Ness big sucker K&N, ISO Grips, 4x1.5 Highway Hawg Risers, extra chrome (never too much), JM 2k CB 4' antena, Mustang seat, HD Front TS & Lowers, OD Pulley

IBA Rider
Retired Navy SCPO
Chesapeake Va
Tims_04V92TC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome