2002 V92C - starter relay clicking - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 05-05-2012, 12:24 PM Thread Starter
Member
 
DaveTV's Avatar
 
Join Date: Apr 2010
Location: Boston, MA USA
Posts: 35
Default 2002 V92C - starter relay clicking

Hey alll, I am trying to start the V92C I picked up - I have yet to hear her run, it has been sitting a few years. I thought it was a battery issue, but even with a new battery, the starter relay just clicks. We are checking connections, fuses etc at the moment, does anyone have any wisdom to assist us in troubleshooting this today? I am dying to hear her run, only 6880 miles on it. Thanks!

EDIT:It is in my friends garage in New Hampshire 60 miles from me, so the next time I go up I want to have a "plan of attack" for troubleshooting the issue. The thing is pretty pristine, I am hoping it's nothing too serious. I took the relay off and cleaned it up, reinstalled, no go. Any sage wisdom for approaching the troubleshooting would be appreciated! I am looking about for the service manual as well, I may go up next Thursday or maybe next weekend.

Last edited by DaveTV; 05-06-2012 at 07:24 AM.
DaveTV is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-07-2012, 07:06 AM
Senior Member
 
Atbyrne's Avatar
 
Join Date: Sep 2011
Location: corydon, in
Posts: 812
Garage
Default

is it a constant click, like a buzz? the relay could be bad or the starter could be locked up. Try rocking bike in gear, hope motor is not locked. Are you sure your battery is good? When I bought my 99 last year the guy had put a battery in it just a few months earlier. Turned out to be a junk battery from walmart. Would cause all kinds of problems. Put a good battery in it and it have made a world of difference.
Atbyrne is offline  
post #3 of 3 (permalink) Old 05-07-2012, 07:45 AM Thread Starter
Member
 
DaveTV's Avatar
 
Join Date: Apr 2010
Location: Boston, MA USA
Posts: 35
Default

Ya, I put a brand new battery in it it, the old one was good as I put it in my old GoldWing commuter bike(I am on it today). I guess that next step is to isolate the problem, and figure out whether the starter and relay are good, obviously don't want to start just replacing electrical components. Is there a way to test the relay, also can I test the starter by hooking a +jumper to the connection on the starter where the big cable hooks on?

EDIT - the starter relay in it is the exact one in the attachment(Tyco V23132 A2001 A200) , but the Polaris website parts list calls for a "2410181" - is the one in it OEM?
Attached Images
File Type: jpg Victory2002_5.jpg (57.5 KB, 9 views)
File Type: jpg V23132_Relay.jpg (34.8 KB, 12 views)

Last edited by DaveTV; 05-07-2012 at 08:11 AM.
DaveTV is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome