Voltage Regulator or something else?? - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 12 (permalink) Old 06-04-2012, 08:30 PM Thread Starter
Premium Member
 
RichardL's Avatar
 
Join Date: May 2010
Location: Beckville, Texas
Posts: 53
Default Voltage Regulator or something else??

The battery on the '02 Deluxe cruiser is not charging.....shows "CH Engine" ever few seconds on speedo..Disconnected battery with engine running and engine dies...is it the regulator or something else?..Thanks for any help....

Since I bought the new XCT the old bike doesn't get rode as much as it should.... Can't understand why...LOL


2012 XCT Stage 1, heel shifter, front and rear chrome bumpers
2002 Deluxe Cruiser Stage 1 (For Sale)
2008 Sportster 1200L (Wife's)
RichardL is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 06-04-2012, 09:33 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,125
Default

I'm going to make some wild guesses here...
Fluid level in battery OK?
Battery & starter relay connections tight?
If bike sits unused is there an automatic trickle charger on it?

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #3 of 12 (permalink) Old 06-04-2012, 10:35 PM Thread Starter
Premium Member
 
RichardL's Avatar
 
Join Date: May 2010
Location: Beckville, Texas
Posts: 53
Default

Quote:
Originally Posted by RICZ View Post
I'm going to make some wild guesses here...
Fluid level in battery OK?
Battery & starter relay connections tight?
If bike sits unused is there an automatic trickle charger on it?
New Battery.....
Connections tight....
Battery Tender Is Connected.....



2012 XCT Stage 1, heel shifter, front and rear chrome bumpers
2002 Deluxe Cruiser Stage 1 (For Sale)
2008 Sportster 1200L (Wife's)
RichardL is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 06-04-2012, 11:51 PM
Member
 
atomicdog's Avatar
 
Join Date: Jan 2012
Location: San Diego
Posts: 48
Garage
Default

If you have a volt meter you can measure the voltage when the bike is running. It should be at least a few volts greater then 12v.

2012 Vegas 8-ball
atomicdog is offline  
post #5 of 12 (permalink) Old 06-05-2012, 04:44 AM
Senior Member
 
Azdave's Avatar
 
Join Date: May 2012
Location: Scottsdale
Posts: 1,331
Default

Check the connection off the voltage regulator. My looked connected but was not making complete contact and that was the problem. I had the same issues as you. Bought new battery and it still occurred, Kevin had me check connector and that was it. Good luck

Blame it on me
2014 HD Street Glide
2013 Vision Sunset Red
2006 Jackpot sold
2006 Vrod Screaming Eagle (sold)
1972 Kawasaki 1000
Azdave is offline  
post #6 of 12 (permalink) Old 06-05-2012, 08:43 AM Thread Starter
Premium Member
 
RichardL's Avatar
 
Join Date: May 2010
Location: Beckville, Texas
Posts: 53
Default

Quote:
Originally Posted by Azdave View Post
Check the connection off the voltage regulator. My looked connected but was not making complete contact and that was the problem. I had the same issues as you. Bought new battery and it still occurred, Kevin had me check connector and that was it. Good luck
Connection off voltage regulator looks clean and tight... Is the bike like a car where it will run off alternator with battery disconnected if alternator or stator is working??? Haven't been into bike electrical systems. Have worked on lots of cars and trucks..


2012 XCT Stage 1, heel shifter, front and rear chrome bumpers
2002 Deluxe Cruiser Stage 1 (For Sale)
2008 Sportster 1200L (Wife's)
RichardL is offline  
post #7 of 12 (permalink) Old 06-05-2012, 09:34 AM Thread Starter
Premium Member
 
RichardL's Avatar
 
Join Date: May 2010
Location: Beckville, Texas
Posts: 53
Default

Just cleaned all connections... Battery voltage is 12.8 with key and engine off and 14.32 with engine running. "CH Engine" shows on speedo regularly in few second intervals....


2012 XCT Stage 1, heel shifter, front and rear chrome bumpers
2002 Deluxe Cruiser Stage 1 (For Sale)
2008 Sportster 1200L (Wife's)
RichardL is offline  
post #8 of 12 (permalink) Old 06-05-2012, 09:54 AM Thread Starter
Premium Member
 
RichardL's Avatar
 
Join Date: May 2010
Location: Beckville, Texas
Posts: 53
Default

"CH ENGINE" displays every 6 seconds on Speedo display....


2012 XCT Stage 1, heel shifter, front and rear chrome bumpers
2002 Deluxe Cruiser Stage 1 (For Sale)
2008 Sportster 1200L (Wife's)
RichardL is offline  
post #9 of 12 (permalink) Old 06-05-2012, 10:25 AM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Vic uses a stator charging system with a shunt regulator. Pull the battery, and the bike dies. Normal. First thing that needs to be done is a throttle point reset[stickied to the top of the tech forum] If light is still on and you are charging. It is something else.
BTW....What does it charge at with the engine spun up to 3000RPM?

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #10 of 12 (permalink) Old 06-05-2012, 11:53 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,949
Default

Bikes are not like cars. If you discount battery when bike is running YES it dies

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome