Starter relay - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 13 (permalink) Old 06-05-2012, 12:42 PM Thread Starter
Lifetime Premium
 
Join Date: Jun 2012
Posts: 9
Default Starter relay

Does the starter relay affect the fuel pump as well? I have issues where the fuel pump and starter don't work, but can cycle the kill switch or ignition and the fuel pump comes on and the starter works.
docsesp250 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 06-05-2012, 12:47 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Quote:
Originally Posted by docsesp250 View Post
Does the starter relay affect the fuel pump as well? I have issues where the fuel pump and starter don't work, but can cycle the kill switch or ignition and the fuel pump comes on and the starter works.
I'm guessing you have a C bike

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #3 of 13 (permalink) Old 06-05-2012, 07:09 PM Thread Starter
Lifetime Premium
 
Join Date: Jun 2012
Posts: 9
Default

It's an '03 V92TC. Was told the turn signals and lights could cause it.
docsesp250 is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 06-05-2012, 08:26 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Look in the fuse box. You will see two diodes that look like black fuses. Switch them around and your bike will start every time. I would recommend replacing them both though.

EDIT: knew it was gonna be a C

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #5 of 13 (permalink) Old 06-05-2012, 10:26 PM Thread Starter
Lifetime Premium
 
Join Date: Jun 2012
Posts: 9
Default

Tried that. The fuel pump relay clicks,but no fuel pump or starter!! I even bypassed the Stop/ Run switch!!

Last edited by docsesp250; 06-05-2012 at 10:28 PM.
docsesp250 is offline  
post #6 of 13 (permalink) Old 06-06-2012, 05:54 AM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Swap the pump relay with the headlight relay

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #7 of 13 (permalink) Old 06-06-2012, 11:52 AM Thread Starter
Lifetime Premium
 
Join Date: Jun 2012
Posts: 9
Default

Did that first. No change! Being intermittent, that's why I thought it might be the starter relay. The relays in the fuse box click when you turn on the ignition but no pump or starter. When it does start, it runs for a few minutes, then dies.

Last edited by docsesp250; 06-06-2012 at 11:55 AM.
docsesp250 is offline  
post #8 of 13 (permalink) Old 06-06-2012, 12:30 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Nothing like a challenge....
When you say runs for a few minutes and then dies. I assume you are talking about the engine. So my next stupid question is. Have you checked the connections at the battery with a wrench and are positive they are clean??

While I'm here. I would recomend checking the crank sensor [left, top, front of case] and make sure it is clipped in tight. Also follow the small red wire from battery + to the circuit breaker, and make sure it maintains power on both sides

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #9 of 13 (permalink) Old 06-06-2012, 01:48 PM Thread Starter
Lifetime Premium
 
Join Date: Jun 2012
Posts: 9
Default

New gel battery, all connections clean and tight. Everything else checks out fine. Where I'm losing power is the purple wire on teh other side of the pump relay. Have got to get a wiring diagram.

Last edited by docsesp250; 06-06-2012 at 02:03 PM.
docsesp250 is offline  
post #10 of 13 (permalink) Old 06-06-2012, 02:37 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Does this thing have an aftermarket airbox???

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome