Anyone else? Rough Idle / Stalling - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 04-29-2015, 11:57 AM Thread Starter
Member
 
Join Date: Oct 2013
Location: Michigan
Posts: 68
Unhappy Anyone else? Rough Idle / Stalling

Have a problem and seeing if anyone else has had issues. Have a 2013 XC. Bike started having a problem where it will randomly start idling and bouncing back and forth upwards of 400RPMs difference. Driving with constant throttle, the same thing happens but with less of an effect: continual jerking as it goes up and down a few hundred RPMs. Yesterday the first corner I pulled up to it stalled when I put in the throttle.

Throttle position sensor? Asked the dealer, said could be a vacuum leak somewhere too. I'm afraid that it might not be covered under warranty either way, and I'm having them check into it before I bring it in.
dashbarron is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-29-2015, 12:28 PM
Lifetime Premium
 
Travis P's Avatar
 
Join Date: May 2013
Posts: 4,498
Default

Check your battery terminal connections and make sure they are tight. I will bet you a six pack that's your issue.
Travis P is offline  
post #3 of 6 (permalink) Old 04-29-2015, 12:30 PM
Senior Member
 
epson390's Avatar
 
Join Date: Aug 2013
Location: CT
Posts: 346
Garage
Default

Quote:
Originally Posted by Travis P View Post
Check your battery terminal connections and make sure they are tight. I will bet you a six pack that's your issue.
^ Agreed, or the battery itself could have gone bad.

2014 XC - Pearl White - 16" Ape Hangers, LED Headlight, Lloydz Timing Gear @ +4, SharkHonker Exhaust, PCV, 1/4" Turn Throttle Ring, Hard Lowers, Keyless Ignition, Lloyd's Intake, Klockwerk Shield
epson390 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-30-2015, 09:23 PM
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default

Quote:
Originally Posted by epson390 View Post
^ Agreed, or the battery itself could have gone bad.

This and that....

Had a battery that was starting to go south and this would happen sporadically

2012 Vegas 8 Ball
LLoydz VM1 drop in cams
LLoydz Adjustable Timing Wheel
LLoydz 1/4 turn throttle ring
RPW Slash Exhaust
S&S Intake
PCV w/AutoTune
Barnett clutch
Pirelli Night Dragon rubber
ChiTownVegas is offline  
post #5 of 6 (permalink) Old 04-30-2015, 09:54 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,826
Garage
Default

Yep. A battery or connection issue can cause all kinds of crazy issues with the Victory bikes. Has something to do with how the ECM communicates with the ignition and injection timing.
BBob is offline  
post #6 of 6 (permalink) Old 05-03-2015, 08:49 PM
Member
 
Defuse's Avatar
 
Join Date: Nov 2013
Posts: 91
Garage
Default

Try resetting your IAC.

a) Kill Switch set to run
b) Turn Key On
c) Let fuel pump prime
d) Turn Key Off
e) Wait for IAC to cycle. It's an audible sound and you can also feel it on the right cheese wedge

Repeat steps 3 times then start the bike.

2013 Zach Ness Cross Country - #110
Lloydz Air Filter // VM1-DR // PCV // ATS // D&D Unwrapped

110 HP // 110 Ft.Lbs
Defuse is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome