Engine light - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 11 (permalink) Old 06-14-2015, 11:18 AM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default Engine light

First long ride on the 8 ball today and as soon as I gunned it off a roundabout the engine light came on and stayed on until I came to rest at a junction,then as soon as I pulled away it came back on again and behaved in this manner all day although it seemed to be running ok and no misfires. The bike is 5 years old with less than 3000 miles on it running the shotgun pipes stage 1 tuning with kn filter etc. Many riders here have pulled the o2 wires,I may try that to clear it.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-14-2015, 11:41 AM
Lifetime Premium
 
OkieHoss's Avatar
 
Join Date: Sep 2011
Location: NE Oklahoma
Posts: 918
Default

I doubt O2 disconnect will do anything. check the most basic of things like batt cables. good luck

2013 black XCT.
OkieHoss is offline  
post #3 of 11 (permalink) Old 06-14-2015, 12:29 PM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default

Just nipped them up with a squirt of loctite to make sure.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 06-15-2015, 11:57 AM
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default

I assume you didn't check the codes? Not certain if the 2010 is the same, but I can pull mine up on the speedo.

2012 Vegas 8 Ball
LLoydz VM1 drop in cams
LLoydz Adjustable Timing Wheel
LLoydz 1/4 turn throttle ring
RPW Slash Exhaust
S&S Intake
PCV w/AutoTune
Barnett clutch
Pirelli Night Dragon rubber
ChiTownVegas is offline  
post #5 of 11 (permalink) Old 06-15-2015, 04:17 PM
Senior Member
 
S.Bobber's Avatar
 
Join Date: Oct 2012
Location: LU
Posts: 148
Default

yea I've been told it could be the O2 sensors while unplugged. I happened to unplug them to run some tests and no light came up.
I would ask the dealer to check the error message. it happened to me a while ago but it was nothing. can't remember why actually.

2014 Victory HighBall
S.Bobber is offline  
post #6 of 11 (permalink) Old 06-16-2015, 05:56 AM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default

Quote:
Originally Posted by ChiTownVegas View Post
I assume you didn't check the codes? Not certain if the 2010 is the same, but I can pull mine up on the speedo.
Codes on speedo? Tell me more.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
post #7 of 11 (permalink) Old 06-16-2015, 06:37 AM
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default

Using the mode button for the display... You can select chk eng or similar to have it tell you the codes set
ChiTownVegas is offline  
post #8 of 11 (permalink) Old 06-16-2015, 07:11 AM
Lifetime Premium
 
Motorbikerx's Avatar
 
Join Date: Dec 2013
Location: Gold Coast, Australia.
Posts: 8,647
Garage
Default

Quote:
Originally Posted by goon View Post
Just nipped them up with a squirt of loctite to make sure.
Did you clean the points of contact on the terminals and leads before reconnecting?

Victory Vegas 2010
Lloydz 109"cube big bore
" " 495 cams
" " TorqueTubes
" " timing wheel @4 deg.
" " Primary plate
" " IAV
RPW Slash pipes
PCV
Progressive 465 rear shock
Kingpin USD Forks
18" XC front wheel
1 3/4" 'Burleigh Bars'
Stebel air horn
12.106 @110.90mph
114/123

Victory Cross Country 2010 (106)
Lloyds air filter
" " VM1 Cams
Home gutted exhaust
Maximus
Both tuned by [email protected] Dyno
110/116

Gold Coast
Australia
Motorbikerx is offline  
post #9 of 11 (permalink) Old 06-16-2015, 04:57 PM
Senior Member
 
S.Bobber's Avatar
 
Join Date: Oct 2012
Location: LU
Posts: 148
Default

Quote:
Originally Posted by ChiTownVegas View Post
Using the mode button for the display... You can select chk eng or similar to have it tell you the codes set
And your dealer will be able to tell you what the code means.
You can find it in the doc coming with the bike too I think.

2014 Victory HighBall
S.Bobber is offline  
post #10 of 11 (permalink) Old 06-17-2015, 10:45 AM Thread Starter
Senior Member
 
Join Date: Oct 2010
Location: Swansea,Wales,UK
Posts: 365
Default

Quote:
Originally Posted by S.Bobber View Post
And your dealer will be able to tell you what the code means.
You can find it in the doc coming with the bike too I think.
Nope,nothing in manual mentioning any error codes or the like,must be on later models maybe.

2008 Suzuki B King,2010 Vegas 8 Ball,2006 BMW Z4.
goon is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome