Bike is cutting out at high RPMs??? - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 25 (permalink) Old 09-14-2012, 06:43 PM Thread Starter
Member
 
ThatGuy321's Avatar
 
Join Date: Jun 2011
Location: Minnesota
Posts: 77
Default Bike is cutting out at high RPMs???

Good afternoon gentlemen,
When I goose the throttle my motor cuts out at high RPM's. I changed the spark plugs and ran some sea-foam through it and still continuing to cut out. The cut out will last a split second (as if it misfired) and the bike feels kind of weak. Could be my mind playing tricks on me by saying I think the bike feels weak. I have about 6000 miles on it.

Ive been running a couple tanks of 110 race fuel in it periodically through out the summer and I feel that has something to do with it acting up. It started acting up when I just about ran out of gas (110 race fuel) and barely made it into the gas station and filled up with 92.

Any tips, advise, help, anything at this point would help before I suck it up and bring it in to the dealer..

https://www.victoryforums.com/album.p...pictureid=3170
2008 Jackpot Extreme Series
* S&S intake
* Arlen Ness Pipes
* Big City Thunder Baffles
* Power Commander III
* Lowered 1.25''
* 1.5'' Chubby drag bars - 7'' rise 7'' pull, as wide as they can come
* Hammer Spike Grips
* Custom Dynamics Dual Color rear bullet signals
* 280 rear/stock wheel
ThatGuy321 is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 09-14-2012, 07:15 PM
Senior Member
 
Tims_04V92TC's Avatar
 
Join Date: Oct 2011
Location: Chesapeake Va
Posts: 1,499
Garage
Default

what did the plugs look like??? Wet fouled, lean or right where they should be?

Asking the obvious, checked the air filter for obstruction or contaminant??

2011 White Vision - Nuvi 550, Lowers, Lloydz 2nd filter, Vic perf filter, CB/Icom, 96 Brake LED's, Clear Signal lens/Switchbacks, VIC Hwy Pegs, Stebel Horn, 7Jurock 15" Shield, PCV, Lloyd ATS and Variable intake, Ness honkers

2004 V92 TC - S1 flash, level 1 slip-on, Ness big sucker K&N, ISO Grips, 4x1.5 Highway Hawg Risers, extra chrome (never too much), JM 2k CB 4' antena, Mustang seat, HD Front TS & Lowers, OD Pulley

IBA Rider
Retired Navy SCPO
Chesapeake Va
Tims_04V92TC is offline  
post #3 of 25 (permalink) Old 09-14-2012, 07:19 PM
Senior Member
 
Join Date: Feb 2012
Location: Fairfield Cnty, CT
Posts: 634
Default

How high rpm's?? Wouldn't be the rev limiter, would it?

2010 XC Midnight Cherry
cams/D&D
2009 Ness Vision
116 Big Bore
"The Millinium Falcon"
Blueline is offline  
Sponsored Links
Advertisement
 
post #4 of 25 (permalink) Old 09-14-2012, 10:18 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,910
Garage
Default

I'd check the plug wire connections, clean them, and use some dielectric grease on 'em. Look closely at the plug wires for issues. Maybe replace them. I'd also check and clean both battery terminal connections and do the same thing. Find where the ground wire goes and check that too.

Sometimes these things are process of elimination and a chance to do some good maintenance.
BBob is offline  
post #5 of 25 (permalink) Old 09-15-2012, 05:39 AM
Lifetime Premium
 
gibson's Avatar
 
Join Date: Jan 2012
Location: North east Indiana
Posts: 1,181
Default

Could be the power commander at that RPM needs adjusted. I had to tweak mine in the power band to get the best performance.

2012 Fireball Jackpot
gibson is offline  
post #6 of 25 (permalink) Old 09-15-2012, 06:55 AM
Senior Member
 
Vicbuilder's Avatar
 
Join Date: Jun 2011
Location: Central Iowa
Posts: 403
Default

Sounds like a fuel pump issue to me. I rebuild them for a fraction of the cost of a new one. Call me or check out my website if interested.

Rylan Vos
The Vic Shop, Inc
(515)-339-4313
Vicbuilder is offline  
post #7 of 25 (permalink) Old 09-15-2012, 10:13 AM
Senior Member
 
handyhoward's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 545
Garage
Default

Plus 1 on the fuel pump or could be a dirty fuel system. At high rpms the demand for fuel is at its highest and a dirty system or even a partially dirty injector nozzle will cause a loss of power. Sea Foam is a good start... but it takes time for the system to get the most out of it.

Handy

2013 Indian Vintage Chief FE... #7 of 25

2011 Victory Vision Tour Premium...
handyhoward is offline  
post #8 of 25 (permalink) Old 09-15-2012, 02:28 PM Thread Starter
Member
 
ThatGuy321's Avatar
 
Join Date: Jun 2011
Location: Minnesota
Posts: 77
Default

Quote:
Originally Posted by gibson View Post
Could be the power commander at that RPM needs adjusted. I had to tweak mine in the power band to get the best performance.
you know i was thinking the same thing however Ive never had an issue with it up until now. And the map cant change unless you physically take the power commander out and hook it up to a lap top.

https://www.victoryforums.com/album.p...pictureid=3170
2008 Jackpot Extreme Series
* S&S intake
* Arlen Ness Pipes
* Big City Thunder Baffles
* Power Commander III
* Lowered 1.25''
* 1.5'' Chubby drag bars - 7'' rise 7'' pull, as wide as they can come
* Hammer Spike Grips
* Custom Dynamics Dual Color rear bullet signals
* 280 rear/stock wheel
ThatGuy321 is offline  
post #9 of 25 (permalink) Old 09-15-2012, 02:34 PM Thread Starter
Member
 
ThatGuy321's Avatar
 
Join Date: Jun 2011
Location: Minnesota
Posts: 77
Default

Quote:
Originally Posted by BBob View Post
I'd check the plug wire connections, clean them, and use some dielectric grease on 'em. Look closely at the plug wires for issues. Maybe replace them. I'd also check and clean both battery terminal connections and do the same thing. Find where the ground wire goes and check that too.

Sometimes these things are process of elimination and a chance to do some good maintenance.
Checked the wires, they seem fine but Im going to go get some elect grease now and see if that doesnt help. I wouldnt doubt it being a fuel pump related issue but being it only has 6000 miles on it, its tough to believe that it would be going belly up already.

https://www.victoryforums.com/album.p...pictureid=3170
2008 Jackpot Extreme Series
* S&S intake
* Arlen Ness Pipes
* Big City Thunder Baffles
* Power Commander III
* Lowered 1.25''
* 1.5'' Chubby drag bars - 7'' rise 7'' pull, as wide as they can come
* Hammer Spike Grips
* Custom Dynamics Dual Color rear bullet signals
* 280 rear/stock wheel
ThatGuy321 is offline  
post #10 of 25 (permalink) Old 09-15-2012, 09:09 PM
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default

On another note, why would you run 110??????

2012 Vegas 8 Ball
LLoydz VM1 drop in cams
LLoydz Adjustable Timing Wheel
LLoydz 1/4 turn throttle ring
RPW Slash Exhaust
S&S Intake
PCV w/AutoTune
Barnett clutch
Pirelli Night Dragon rubber
ChiTownVegas is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome