Ping from Hell - Victory Forums - Victory Motorcycle Forum
 8Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 108 (permalink) Old 08-14-2015, 09:28 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default Ping from Hell

OK , got a tune from KMC in April . Bike ran , and runs strong still but has developed a ping under hard acceleration . Timing wheel is set at +4 and the PCV timing @ 80% and 100% was also at +4 . I have since dropped the PCV advance in different stages and still had the ping . I ended up at 80% +1 100% +2 and thought I had it solved , but had a ping today when ripping it up on the freeway @ 55F temps . Never had this ping till a month ago or so with Mamma on the back and hot temps at the time . Spoke with KevinX and he had some things to check , all checks out OK . I always use the highest octane available (usually 93) Don't understand why this is happening , going to zero out the PCV timing when I get home tonight . If its still present I will have to start chipping away at the timing wheel advance ....Any suggestions ? Faulty PCV maybe ? I'm tapped on this one .

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
Sponsored Links
Advertisement
 
post #2 of 108 (permalink) Old 08-14-2015, 09:34 AM
Senior Member
 
epson390's Avatar
 
Join Date: Aug 2013
Location: CT
Posts: 346
Garage
Default

Did you read my mind? Mags I'm going to text you. My bike is now doing the exact same thing.

2014 XC - Pearl White - 16" Ape Hangers, LED Headlight, Lloydz Timing Gear @ +4, SharkHonker Exhaust, PCV, 1/4" Turn Throttle Ring, Hard Lowers, Keyless Ignition, Lloyd's Intake, Klockwerk Shield
epson390 is offline  
post #3 of 108 (permalink) Old 08-14-2015, 09:41 AM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,341
Garage
Default

Did you lose power? Timing wheel adjustment come loose?



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +5, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is offline  
Sponsored Links
Advertisement
 
post #4 of 108 (permalink) Old 08-14-2015, 09:49 AM
Senior Member
 
epson390's Avatar
 
Join Date: Aug 2013
Location: CT
Posts: 346
Garage
Default

I didnt notice any power loss with mine but I feel like the engine noise is getting slightly louder each day. I started panicking thinking the PCV died and I am starting to run lean but I am not noticing any power change at the throttle. I also noticed I dont really hear anything when the bike is idling other than the normal sounds it makes. I checked yesterday for exhaust leaks to see if I had a cracked head pipe but they looked fine.

Also I noticed that the sound change is primarily between 2 and 3 on the rpm range.

2014 XC - Pearl White - 16" Ape Hangers, LED Headlight, Lloydz Timing Gear @ +4, SharkHonker Exhaust, PCV, 1/4" Turn Throttle Ring, Hard Lowers, Keyless Ignition, Lloyd's Intake, Klockwerk Shield
epson390 is offline  
post #5 of 108 (permalink) Old 08-14-2015, 09:51 AM
Senior Member
 
epson390's Avatar
 
Join Date: Aug 2013
Location: CT
Posts: 346
Garage
Default

Quote:
Originally Posted by broggyr View Post
Did you lose power? Timing wheel adjustment come loose?
I am going to recheck the timing wheel tonight since I am also now realizing it feels more luggish (if thats a word) in lower rpm range.

2014 XC - Pearl White - 16" Ape Hangers, LED Headlight, Lloydz Timing Gear @ +4, SharkHonker Exhaust, PCV, 1/4" Turn Throttle Ring, Hard Lowers, Keyless Ignition, Lloyd's Intake, Klockwerk Shield
epson390 is offline  
post #6 of 108 (permalink) Old 08-14-2015, 09:54 AM
Premium Member
 
dtmmil's Avatar
 
Join Date: Jul 2012
Location: Hawley MN
Posts: 4,178
Default

not questioning here, but your 100% sure its ping right?? i had a guy asking me about his, he swore it was ping, turned out to be engine noise and not ping.

currently bikeless

2012 Cross Country(Imp blue)
de-badged,(self tinted) Klockwerx flare, passenger backrest, passenger touring floorboards, VictoryHID kit, Miller Mufflers short baffles,Lloyds air filter(from witchdr.)Lloyds timing wheel(6*), adjustable drop link, cut seat, removed cats, PCV w/at.
1978(2009) Honda cb750 chopper
Hawley MN(sold)
dtmmil is offline  
post #7 of 108 (permalink) Old 08-14-2015, 09:54 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Quote:
Originally Posted by broggyr View Post
Did you lose power? Timing wheel adjustment come loose?
I pulled the cam cover and all was perfect in there ....

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #8 of 108 (permalink) Old 08-14-2015, 09:55 AM
Premium Member
 
dtmmil's Avatar
 
Join Date: Jul 2012
Location: Hawley MN
Posts: 4,178
Default

fastest thing to do is swap the stock wheel and go got a ride.
jazzdogg likes this.

currently bikeless

2012 Cross Country(Imp blue)
de-badged,(self tinted) Klockwerx flare, passenger backrest, passenger touring floorboards, VictoryHID kit, Miller Mufflers short baffles,Lloyds air filter(from witchdr.)Lloyds timing wheel(6*), adjustable drop link, cut seat, removed cats, PCV w/at.
1978(2009) Honda cb750 chopper
Hawley MN(sold)
dtmmil is offline  
post #9 of 108 (permalink) Old 08-14-2015, 09:56 AM
Super Moderator
 
broggyr's Avatar
 
Join Date: Apr 2013
Location: Naugatuck, CT
Posts: 6,341
Garage
Default

I figured that would be one of the things kx asked to check...



2013 XCT, Boardwalk Blue w/ Vicwrapz
S&S Cams, Lloydz filter & ATS +5, PCV, UD pulley, Alto Red Eagle clutch plates
Madstad Windshield, 5000K HID, TriOvals, Memphis Shields wings, Ultimate seat
JVC KD-X35MDT, PBR300X4, Polk DB6502, DaytonAudio ND140-4 rear
HyperLites, LED driving lights, Lloydz dyno 105+H and 117+T
Arlen Ness blinkers, KlockWerks KlipHanger bars, Avon grips

Spectro Golden 4 20w40 for Victory L.SG424, Kury Sabertooth LEDs
THE FEW, THE PROUD, THE OBSCURE. TTWFO2
broggyr is offline  
post #10 of 108 (permalink) Old 08-14-2015, 09:57 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Quote:
Originally Posted by dtmmil View Post
not questioning here, but your 100% sure its ping right?? i had a guy asking me about his, he swore it was ping, turned out to be engine noise and not ping.
When I was running +3 80 and +3 100 I would have a slight hesitation an instant before I heard the ping , it sounds like rocks being slung though the front fender . As I have been lowering the timing and riding the noise has subsided , I thought I had it cured before this mornings run ....

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome