Led turn signal problems - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 15 (permalink) Old 03-12-2013, 02:33 PM Thread Starter
Member
 
Join Date: Jun 2012
Location: MA
Posts: 40
Default Led turn signal problems

I just hooked up some rear turn signal LEDs on my 2012 hammer 8ball and i lost all turn signals and the tail light. Brake light works ok, headlight works, but no turn signals. Checked the fuse and its fine. I hooked up a load equalizer as well. Any suggestions as to what could be wrong?

Sent from Motorcycle.com Free App

2012 Hammer 8 Ball
theblade88 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 03-12-2013, 02:42 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by theblade88 View Post
I just hooked up some rear turn signal LEDs on my 2012 hammer 8ball and i lost all turn signals and the tail light. Brake light works ok, headlight works, but no turn signals. Checked the fuse and its fine. I hooked up a load equalizer as well. Any suggestions as to what could be wrong?

Sent from Motorcycle.com Free App
1.) Are all turn signals not working? (front left, front right, rear left, rear right?)
2.) When turn signal switch is flipped to left or right, does the turn signal indicator flash? If yes, does it flash normal speed, or does it flash 2-3 times faster than normal?
3.) If you turn on the 4-way flashers, do they work?
4.) Do you have a voltmeter handy?

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #3 of 15 (permalink) Old 03-12-2013, 02:59 PM Thread Starter
Member
 
Join Date: Jun 2012
Location: MA
Posts: 40
Default Re: Led turn signal problems

None of the flashers work, hazards dont work, and theres nothing on the display to indicate the turn signals are on. Unfortunately I dont have a voltmeter handy

Sent from Motorcycle.com Free App

2012 Hammer 8 Ball
theblade88 is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 03-12-2013, 03:43 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by theblade88 View Post
None of the flashers work, hazards dont work, and theres nothing on the display to indicate the turn signals are on. Unfortunately I dont have a voltmeter handy

Sent from Motorcycle.com Free App
Try swapping the fuel pump relay with the flasher relay, and test again.

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #5 of 15 (permalink) Old 03-12-2013, 03:51 PM Thread Starter
Member
 
Join Date: Jun 2012
Location: MA
Posts: 40
Default

I had to walk away from it for now, I'll give that a shot when I get another chance to tackle it.

2012 Hammer 8 Ball
theblade88 is offline  
post #6 of 15 (permalink) Old 03-12-2013, 04:10 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by theblade88 View Post
I had to walk away from it for now, I'll give that a shot when I get another chance to tackle it.
Okay. Just make sure when you test it, that the key is in the ON position and that the kill switch is in the RUN position. When you're frustrated about something not working, these little things can easily be overlooked.

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #7 of 15 (permalink) Old 03-12-2013, 04:13 PM Thread Starter
Member
 
Join Date: Jun 2012
Location: MA
Posts: 40
Default

Will do. One thing I forgot to mention is that the fuse for the horn was blown. Not sure if that would make a difference or not.

2012 Hammer 8 Ball
theblade88 is offline  
post #8 of 15 (permalink) Old 03-12-2013, 04:24 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by theblade88 View Post
Will do. One thing I forgot to mention is that the fuse for the horn was blown. Not sure if that would make a difference or not.
Yes it does make a difference. Horn and flashers share the same fuse. Replace the fuse.

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #9 of 15 (permalink) Old 03-12-2013, 04:30 PM Thread Starter
Member
 
Join Date: Jun 2012
Location: MA
Posts: 40
Default

that figures. like you said sometimes it's the little things. Thanks for the help!!!

2012 Hammer 8 Ball
theblade88 is offline  
post #10 of 15 (permalink) Old 03-12-2013, 10:36 PM
Member
 
joshn's Avatar
 
Join Date: Oct 2012
Location: San Antonio, TX
Posts: 96
Default Led turn signal problems

Good to know for in the future! thanks never know when I might need that tid bit of info


Sent from Motorcycle.com Free App

2013 Vegas 8 Ball, 6k HID, Hacker Ripper Pipes and FMS
joshn is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome