Tail light / brake light OUT - Victory Forums - Victory Motorcycle Forum
 21Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 91 (permalink) Old 10-19-2016, 07:03 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default Tail light / brake light OUT

Guy pulled up to me in traffic this morning on my way to work to tell me I had nothing lighting up in the rear , which is disturbing since I left my home @ 5:45 AM , pitch black . I pulled into Dunky's to access the situation , sure enough nothing . I tapped on the tail light and it flickered and came on , I hit the brake and it went off again , tapped it , it flickered and came back on , braked , off again . Anyone have this issue in the past , seems like a bad connection at the tail light but it being LED it may be the light itself ? Looks like an ass pain to remove or get to the connection ....

Regardless , I have to ride it home tonight and may not get home until after dark so I am fairly alarmed here , any ideas would be great !

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
Sponsored Links
Advertisement
 
post #2 of 91 (permalink) Old 10-19-2016, 07:27 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Got the rear lighting diagram from the service manual , I see a nice pinpoint test . Does anyone know off hand where the rear brake light to chassis connector is ? I believe its on the right side of the bike but I may be mistaken , looks to be a 6 cavity connector ..... Why doesn't this stuff happen to me when I'm in my garage with the day off ?

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #3 of 91 (permalink) Old 10-19-2016, 08:08 AM
Senior Member
 
Join Date: Sep 2014
Location: Hendersonville, NC in summers and The Villages, FL in winters
Posts: 1,402
Default

I had a problem with the tail/brake light on a 2012 XCT. It was really odd and intermittent. Sometimes the entire tail light would work great. Sometimes the top half of the tail light LED bulbs would go out. The brake light always worked but each time I pressed the brake, it would change the behavior of the tail light bulbs. The tail/brake light assembly is sealed and not servicable. I replaced the entire unit. Of course, if you wanted to cut it open, you would probably find a broken 5 cent resistor on the circuit board. You woudl still have to fix the problem and then find a way to seal the unit against water again.

It is a royal pain to get the brake/tail light unit out of the bike. You have to partially remove the fender to access the removal bolts that are on the inside of the fender. I took off the bags, unscrewed the bag/guard mounting bracket bolts on both sides, removed the smaller bolts that hold the fender on (four of them I believe) and was then able to tilt the rear of the fender upwards allowing access to the brake/tail light bolts and the wire connector for the brake/tail light.

A new brake/tail light unit was somewhere around $150.

G'day,

Vinish
wspollack likes this.

G'day,

Vinish

Our patriotic stable:

Red 2012 XCT (wife's bike in NC)
Red 2012 XCT (my bike for NC)
White with custom flames 2012 XCT (wife's bike in FL)
Blue custom fire on a black 2012 XCT (my bike in FL)

2006 HD Softail Heritage (my bike when I was in MI - sold in Oct, 2017 after putting 45,000 miles and 20 states and one province on it - My first big bike and most of us will always remember our first with fond memories)
Vinish is offline  
Sponsored Links
Advertisement
 
post #4 of 91 (permalink) Old 10-19-2016, 08:28 AM
Senior Member
 
Join Date: May 2013
Location: Left Coast, Canada
Posts: 883
Default

I don't believe in coincidences when it comes to electo-mechanical problems. With your recent tx woes and being in the shop I would first suspect and look for a faulty connection or pinched wiring.

2

Not all those who wander are lost.

2011 Kingpin
53canuck is offline  
post #5 of 91 (permalink) Old 10-19-2016, 08:30 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

I'm afraid I may be looking at a new tail light , cant get my hand up far enough to check the connector , but it does seem like its the light itself since it seems to be getting power and is flickering when tapped and goes right out when brake is applied .... Thanks for your input , tail light now goes for 209.00 if I pay full price , I will check with Paulie @ HET , he takes good care of us . If it is my light assembly , I'm probably done for the season ....

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #6 of 91 (permalink) Old 10-19-2016, 09:46 AM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,702
Garage
Default

Sounds like you might have to remove the taillight anyway to check it. I'd definitely be looking for a frayed wire or poor ground too though.

Quote:
Why doesn't this stuff happen to me when I'm in my garage with the day off ?
Isn't the answer obvious? It's all hitlery's fault of course. Somehow her evil aura managed to reach your bike and screw something up.

Hmmm... maybe there is one or two things that aren't her or obie's fault I suppose.
steele11b and MaddogUSMC like this.
BBob is offline  
post #7 of 91 (permalink) Old 10-19-2016, 09:48 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Quote:
Originally Posted by BBob View Post

Hmmm... maybe there is one or two things that aren't her or obie's fault I suppose.
Highly UNLIKELY .......

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #8 of 91 (permalink) Old 10-19-2016, 10:17 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Quote:
Originally Posted by 53canuck View Post
I don't believe in coincidences when it comes to electo-mechanical problems. With your recent tx woes and being in the shop I would first suspect and look for a faulty connection or pinched wiring.

2
I appreciate it , now that I recall on a mid August ride with spanknut24 , he told me on one of our stops he saw my taillight flicker a few times ... This was before my repair . I'm really hoping to find a loose connection rather then a new light . Whatever it is , it seems to be right at the light , tapping it causes it to come back on , or to at least flicker .....

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #9 of 91 (permalink) Old 10-19-2016, 10:18 AM Thread Starter
Lifetime Premium
 
LILMAGS500's Avatar
 
Join Date: Apr 2013
Location: Peoples Republic of Massachusetts
Posts: 9,684
Garage
Default

Like Vinish said earlier , its probably an internal issue with the light .

2014 Cross Country
2014 XC , Lloyds A/F , Timing Wheel +4 , PCV , Miller Mufflers , 1/4 Turn Throttle Ring , Dyno Tuned by KMC Powersports 98HP 113 TQ
LILMAGS500 is offline  
post #10 of 91 (permalink) Old 10-19-2016, 10:36 AM
Senior Member
 
Join Date: Sep 2014
Location: Hendersonville, NC in summers and The Villages, FL in winters
Posts: 1,402
Default

While mine would not flicker or change by tapping, it would flicker and change randomly and whenever the brake was pressed and then released.

G'day,

Vinish

G'day,

Vinish

Our patriotic stable:

Red 2012 XCT (wife's bike in NC)
Red 2012 XCT (my bike for NC)
White with custom flames 2012 XCT (wife's bike in FL)
Blue custom fire on a black 2012 XCT (my bike in FL)

2006 HD Softail Heritage (my bike when I was in MI - sold in Oct, 2017 after putting 45,000 miles and 20 states and one province on it - My first big bike and most of us will always remember our first with fond memories)
Vinish is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome