Please help - Signal issues on a 2012 (non-acm bike) - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old 03-21-2013, 02:51 PM Thread Starter
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default Please help - Signal issues on a 2012 (non-acm bike)

Had the bike apart to powder coat a bunch of parts. Replaced the signals with a new LED setup (the old LEDs worked just fine). The only thing done differently is that the new lights came with a running light wire (ran to the license plate light) and signal wire (ran to signal). I have tried disconnecting the running lamp portion and it doesn't make a difference.

Now, the relay for the turns just buzzes and won't provide power to the lights. I guess my powder guy found a site that said someone replaced their relay with a Ford part, but didn't list the Ford part #.

Any clue what's happening? Need to get this back together like yesterday

2012 Vegas 8 Ball
LLoydz VM1 drop in cams
LLoydz Adjustable Timing Wheel
LLoydz 1/4 turn throttle ring
RPW Slash Exhaust
S&S Intake
PCV w/AutoTune
Barnett clutch
Pirelli Night Dragon rubber
ChiTownVegas is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 04-06-2013, 11:44 AM Thread Starter
Senior Member
 
ChiTownVegas's Avatar
 
Join Date: Mar 2012
Posts: 329
Default

Well, I sort-of figured it out. I had the ignition on but lights won't work unless engine is RUNNING.

I would guess this is a bad voltage from the battery, but she fires up without a hiccup. Guess it doesn't matter if they don't work without it running, but still kinda odd.

2012 Vegas 8 Ball
LLoydz VM1 drop in cams
LLoydz Adjustable Timing Wheel
LLoydz 1/4 turn throttle ring
RPW Slash Exhaust
S&S Intake
PCV w/AutoTune
Barnett clutch
Pirelli Night Dragon rubber
ChiTownVegas is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome