What would cause... - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 9 (permalink) Old 04-22-2013, 08:51 PM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 43
Default What would cause...

popping from my exhaust ONLY after the bike warms up? After installing Bassani Pro Street Turn Outs, S&S intake, PC-V and having the bike Dyno Tuned the vast majority of the popping is gone. What little I get is on decel and its generally only one single small pop...no big deal and not something I am worried about. Just curious why the pop is only present when the bike is warm. If I turn it on cold I can blip the throttle all I want and get ZERO popping but once the bike is warmed up and the idle RPM's drop back to normal I will start getting the pop. What would be the cause of that? 2011 Victory Vegas 8 Ball with above mods!
8BallMike is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 04-23-2013, 03:38 AM
Senior Member
 
Join Date: Sep 2012
Location: Chicopee Mass. 01020
Posts: 103
Default

I just switched my exhaust to what you have,I get the pop but i thought it was the way i was riding, "not to easy on throttle" if you catch what im saying.. My next investment is the Lloydz IAV from what i read should fix all concerns, but you have the PC-V, it might be worth the $80 to try...

2009 Vegas,Stage 1 Flash, Bassani Pro Street Turn Outs,Arlen Ness 12" Modular Bars,Arlen Ness Smooth Fusion Grips,Victory HID,Side Mount Custom Plate Bracket and Frame,Arlen Ness 2" Rear Speeding Bullets,1.5'' lowering links...

Cherry/pearl white.

Chicopee Ma. 01020
HoodsBackVegas is offline  
post #3 of 9 (permalink) Old 04-23-2013, 05:03 AM
Lifetime Premium
 
half_crazy's Avatar
 
Join Date: Sep 2011
Location: Southern Maryland
Posts: 4,836
Default

You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.

2006 Victory Kingpin
Lloydz 116" Stroker/Big Bore, .495 Cams, Torque Tubes Airbox,
RPW Thor Pipe, Lloydz ECU Flash, PC-III, PTS (-2), Rivera
Primo Clutch Spring, 31 Tooth Pulley w/Buell Belt.
half_crazy is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 04-23-2013, 05:18 AM
Lifetime Premium
 
GatorJoe's Avatar
 
Join Date: Oct 2012
Location: Lake City, FL
Posts: 1,018
Garage
Default

Quote:
Originally Posted by half_crazy View Post
You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.
Totally correct here .. Just adding that once added Auto Tune stopped the popping and rarely get just a crackle now and then through gear changes that have to listen for or wouldn't hear them ...

2017 Indian Chieftain Dark Horse/2005 Dyna Super Glide
GatorJoe is offline  
post #5 of 9 (permalink) Old 04-23-2013, 06:54 AM
Senior Member
 
jackwithcorona's Avatar
 
Join Date: Apr 2012
Location: New England
Posts: 220
Default

Quote:
Originally Posted by half_crazy View Post
You should let the engine warm up before you ride off on it. The reason it doesn't pop when cold is it runs richer until it reaches operating temperature.
I always let the bike warm up, I never ride a cold motor. Im looking at a similar setup, you think that IAV would fix this? I was going to get one anyways

2006 Suzuki SV650 (Traded)
2012 Victory Vegas 8-Ball (Traded)
2014 Victory Cross Country
1985 Harley XLH
jackwithcorona is offline  
post #6 of 9 (permalink) Old 04-23-2013, 05:14 PM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 43
Default

Quote:
Originally Posted by HoodsBackVegas View Post
I just switched my exhaust to what you have,I get the pop but i thought it was the way i was riding, "not to easy on throttle" if you catch what im saying.. My next investment is the Lloydz IAV from what i read should fix all concerns, but you have the PC-V, it might be worth the $80 to try...

If you get the IAV please post your results here if you dont mind. Would love to hear how it works out for you!
8BallMike is offline  
post #7 of 9 (permalink) Old 04-23-2013, 05:21 PM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 43
Default

Also might be worth mentioning that if I am in for example 4th and down shift to 3rd without rolling back on the throttle it will go, "poppopop, pop, pop." Is that normal or a sign of a exhaust gasket leak. Would an exhaust leak have shown on my dyno run. The bike made 97Hp and 108 ftlbs of torque

8BallMike is offline  
post #8 of 9 (permalink) Old 04-23-2013, 05:35 PM
Senior Member
 
Join Date: Mar 2013
Location: Grand Forks, ND by way of Cincy
Posts: 427
Default

Is the first run file stock?
shanko is offline  
post #9 of 9 (permalink) Old 04-23-2013, 05:52 PM Thread Starter
Member
 
Join Date: Dec 2012
Posts: 43
Default

Quote:
Originally Posted by shanko View Post
Is the first run file stock?
No those are front and rear cylinder.
8BallMike is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome