Electrical Problem, need help with diagnosis - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 08-17-2011, 07:13 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
Default Electrical Problem, need help with diagnosis

I don't know much about electronics, so please forgive my ignorance.

Vegal Low, 2008 model, 3650 miles on it. Turned the key to the On position, lights went on, fuel pump primed, pressed the start button, it made a noise like an electrical component failed or shorted out.

Now, turn the key to the On position and nothing happens, no lights, no fuel pump priming, nothing.

Checked fuses in the fuse box, all are good. Checked the fuse on the battery cable, it's ok. Battery is charged.

Could it be a relay problem? How do I test a relay?

Any help is much appreciated.

Mark
MinnesotaVegasLow is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-17-2011, 08:12 PM
Lifetime Premium
 
NOEMTZ's Avatar
 
Join Date: Jul 2009
Location: TEXAS
Posts: 1,567
Garage
Default

Remove and clean battery connections. reattach and try again. Also possible bad cell or two in battery.

www.noemtz.com
Parts & Accessories, Grips, Pegs,Tail Lights, Clear Signal Lenses, Clutch Cable Repair Kits, Custom Tank Badges, Brake Pads, Led Conversions and installation, 12 Volt Adaptors, Chrome, Dyna Beads Wheel Balancing, Heel Blades, Kickstand extensions and much more!

"I Would Rather Die On My Feet, Than Live On My Knees...Emiliano Zapata - 1910"
I DONT PICK SIDES, GO WITH THE FLOW, OR PUT UP WITH BULLSHIT.
I RELY SOLELY ON MYSELF, BEAUSE I HAVE MY OWN BACK. NOEMTZ - 2010
NOEMTZ is offline  
post #3 of 6 (permalink) Old 08-17-2011, 09:31 PM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

Quote:
Originally Posted by NOEMTZ View Post
Remove and clean battery connections. reattach and try again. Also possible bad cell or two in battery.
that is where I would start

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 08-18-2011, 12:29 AM
Senior Member
 
Tenac's Avatar
 
Join Date: Sep 2010
Location: AZ
Posts: 257
Default

If nothing comes one at all start with battery then go straight to the 40 amp breaker thats the only thing between battery and fuse box.

2008 Hammer
LED
2 into 1 No baffle
Lloydz intake
Power Commander 3
CHROME
Speakers
Tenac is offline  
post #5 of 6 (permalink) Old 08-18-2011, 04:48 AM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
Default thanks

Thanks for all the help, I'll give these things a try right after work today.
MinnesotaVegasLow is offline  
post #6 of 6 (permalink) Old 08-18-2011, 05:00 PM Thread Starter
Junior Member
 
Join Date: Aug 2009
Posts: 28
Default Problem solved

Loose battery cable was the issue.

Thanks much for all the help, saved me from a big headache.
Mark
MinnesotaVegasLow is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome