Above 85 out and motor pings alot ! - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 25 (permalink) Old 09-06-2011, 06:13 PM Thread Starter
Junior Member
 
Join Date: Sep 2011
Posts: 6
Default Above 85 out and motor pings alot !

Hello
I have a 2011 kingpin 106. I bought in April.
Just got back from 3000 mile trip.
When I am pulling a hill at 2500rpm and got to speed up.
The motor pins loud too. I have to down shift two gears
And get her up to 4600rpm to make better or just keep rolling out of the throttle.
She has a blow head gasket now dealer is fixing.
Always run 91 octain have sweep pipes and kn filter dealer installed.
I am in CA
Please help thanks Shawn
Thanks for the help Dealer said head gasket ok it was grease from exhaust. They said that they did nothing but bike does not ping or pop out exhaust like it used to. I think they forgot to flash it for pipes.
Thanks again all good
Shawn at JEFFco

Last edited by Jeffco; 09-12-2011 at 12:12 PM. Reason: New info.
Jeffco is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 09-06-2011, 06:24 PM Thread Starter
Junior Member
 
Join Date: Sep 2011
Posts: 6
Default 106 2011 motor pinging up every hill when it's hot out

It a 2011 kingpin swept pipes kn filter
I have to down shift 2 gears to get to 4600 rpm to help pinging..
Or get out of the throttle an just slow down.
Not a little pinging it's loud and bad. Got her in April has 10,000 miles now and a blow head gasket
Thank for any help Shawn at JEFFco

Last edited by Jeffco; 09-06-2011 at 08:40 PM.
Jeffco is offline  
post #3 of 25 (permalink) Old 09-06-2011, 11:52 PM
Senior Member
 
Join Date: Mar 2011
Location: Buckeye, Az.
Posts: 1,415
Default

Was it running toooo leeeeeeeeeean possibly? Thus the pinging and blown headgasket. When an engine pings it is like an explosion inside the cylinder,things can come apart.
Speedblue is offline  
Sponsored Links
Advertisement
 
post #4 of 25 (permalink) Old 09-07-2011, 01:30 AM
Senior Member
 
Bad V V's Avatar
 
Join Date: Mar 2011
Location: Los Angeles
Posts: 755
Default

I kind of don't get it. What do you want us to help you with? You have a blown head gasket and dealer is fixing it. My guess is your bike was running funny because it wasn't right to begin with so it blew the head gasket. I say let the dealer fix your bike take it for a ride and if it still is making funny pinging noises then we'll try to help you.

2003 Victory vegas
Bad V V is offline  
post #5 of 25 (permalink) Old 09-07-2011, 07:55 AM
Senior Member
 
handyhoward's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 545
Garage
Default

Quote:
Originally Posted by Jeffco View Post
Hello
I have a 2011 kingpin 106. I bought in April.
Just got back from 3000 mile trip.
When I am pulling a hill at 2500rpm and got to speed up.
The motor pins loud too. I have to down shift two gears
And get her up to 4600rpm to make better or just keep rolling out of the throttle.
She has a blow head gasket now dealer is fixing.
Always run 91 octain have sweep pipes and kn filter dealer installed.
I am in CA
Please help thanks Shawn
Shut up and quit your bitching... Polaris/Victory don't make mistakes... you obviously have done something to make this bike not run properly. It's a fluke so we can't (spelled "won't") help you figure it out. LMAO

Handy

2013 Indian Vintage Chief FE... #7 of 25

2011 Victory Vision Tour Premium...
handyhoward is offline  
post #6 of 25 (permalink) Old 09-07-2011, 08:35 AM
Senior Member
 
wesdalton's Avatar
 
Join Date: May 2010
Location: Utah
Posts: 679
Default

Quote:
Originally Posted by handyhoward View Post
Shut up and quit your bitching... Polaris/Victory don't make mistakes... you obviously have done something to make this bike not run properly. It's a fluke so we can't (spelled "won't") help you figure it out. LMAO
You sound like a broken record, find a hobby other than wasting space on the forum

2010 X C
wesdalton is offline  
post #7 of 25 (permalink) Old 09-07-2011, 10:18 AM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Guys, don't throw punches unless the target's already wearing a full face helmet. Safety first.

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #8 of 25 (permalink) Old 09-07-2011, 10:59 AM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,818
Garage
Default

Quote:
Originally Posted by Jeffco View Post
It a 2011 kingpin swept pipes kn filter
I have to down shift 2 gears to get to 4600 rpm to help pinging..
Or get out of the throttle an just slow down.
Not a little pinging it's loud and bad. Got her in April has 10,000 miles now and a blow head gasket
Thank for any help Shawn at JEFFco
Sounds like a bad tune. If it had been re-flashed, and I'm assuming you had the Stage 1 flash already done, then it probably would have avoided the down time. Gotta wonder what other damage has been done to the motor that won't show up right away as well.

Did you install the pipes and filter? Did you get the Stage 1 flash?
BBob is offline  
post #9 of 25 (permalink) Old 09-07-2011, 11:45 AM
Senior Member
 
Bad V V's Avatar
 
Join Date: Mar 2011
Location: Los Angeles
Posts: 755
Default

Sounds like it was the wrong octane gas made it all start.

2003 Victory vegas
Bad V V is offline  
post #10 of 25 (permalink) Old 09-07-2011, 02:38 PM
Senior Member
 
kingpin6634's Avatar
 
Join Date: Apr 2011
Location: Lee's Summit Missouri
Posts: 129
Default Re: Octane

I get some mild pinging on my 06 KP. I run 91 octane because that is all I can find. I can't find 93 octane around anymore. Should we be using Octane booster if all we can find is 91?

I just installed the Stage 1 slip on kit and had the dealer remap the bike. Still get a little pinging.

I know in a car engine pinging is called pre-ignition and happens because of timing issues. I think it is caused by the timing being to advanced. Is it the same for our Victory KPs?

'06 Kingpin BIG RED
Has:
Custom Seat
Edge Bags with Ghost Brackets
Chrome Battery Cover
Chrome Starter Cover
Chrome Oil Cooler Cover (KINGPIN)
Chrome Driver Floor Boards
Victory Chrome Gear Box Insert
Lay Down License Plate Bracket
Kewlmetal 2" Pullback Risers
Stage 1 Exhaust Kit


Coming Soon:
After Market Turn Signals Front and Back

Money is no option, but without it my options are limited.
kingpin6634 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome