06 Jackpot AN turn signal issues - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 03-21-2014, 06:32 PM Thread Starter
Junior Member
 
Join Date: Mar 2014
Posts: 11
Default 06 Jackpot AN turn signal issues

I just upgraded the stock front turn signals to bullet LEDs and I added a load equalizer (MBW LR10) because I already had the rear LED light bar. I double checked the right front power wire and it was crossed so I lined up the blue/red with the black to be correct.

When I turn my turn signals on in either direction, I basically get hazard lights, both sides blinking. The rear LED light bar has the correct side a little brighter than the side that shouldn't be lit up. The fronts are equally bright. I can't figure out what I did wrong. I disconnected the rear fender electrical connection and the fronts continue to do the same, so I had to do something wrong but I can't figure out what. The LE looks right, the signals were not complicated. Anyone know what might cause this behavior?

I just found a new issue. My tail light (just replaced with an 09 ness 12v tailight) isn't working properly either. I added the 12v adapter but it only turns on when I depress the brake, it doesn't turn on otherwise. I must have screwed up the load equalizer but I looked again and it looks right.

UPDATE: It's definitely something to do with the load equalizer. I disconnected it and the blinkers work correctly, they just blink fast. I have the yellows on solid blue and blue with red strip and the black is on black, that's right, right? I'm looking for my LE directions again. My rear tail light still won't come on without depressing the brake, that seems to be a separate issue.

2006 AN Jackpot
Manchester, NH

Last edited by Tridecaphi; 03-21-2014 at 07:09 PM.
Tridecaphi is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-22-2014, 12:58 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,947
Default

who's load equalizer is it and maybe its not the right one.
what do you have for checking power and ground

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 3 (permalink) Old 03-22-2014, 01:19 PM Thread Starter
Junior Member
 
Join Date: Mar 2014
Posts: 11
Default

It's the MBW LR10 bought from custom dynamics. http://www.customdynamics.com/victor..._w/connectors_

I'm really thinking it's defective because if I only hook up a single yellow with the black, it doesn't change the blinker speed but doesn't cause everything to blink at once. It seems like there is a short across both yellows. I just tested the two yellows and I have continuity across them, that would seem to indicate that is the cause of the short, right? Does that conclude it's defective?

2006 AN Jackpot
Manchester, NH

Last edited by Tridecaphi; 03-22-2014 at 01:26 PM.
Tridecaphi is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome