2010 Jackpot turn signals do not work - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 09-16-2011, 07:43 PM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 13
Default 2010 Jackpot turn signals do not work

Good evening all,
The turn signals on my 2010 Jackpot do not turn on when I flip the switch. Also, when I flip the emergency switch the signals do not flash. However, if i leave the bike turned off for an extended period of time and I turn on the emergency lights all four will light up and stay on. No flash. If I flip the switch off and then on again they will not light back up. I've had the same thing happen very sporadically with the turn signal. Power off for a long time, key on, flip turn signal switch and the corresponding side's signals with stay on. No flash. Push the button in to turn off they wont come back on. I've literally tried everything to figure this out. However, could this be something with the ACM on the motorcycle? What else could it be?
cyclemonkey is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 09-16-2011, 09:58 PM
New Member
 
Join Date: Aug 2011
Location: Long Island, NY
Posts: 526
Default

Sounds like a burnt ACM. I could be wrong tho.
TrashmanNYC is offline  
post #3 of 6 (permalink) Old 09-17-2011, 06:43 AM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 13
Default

I think you're probably right. It's not the switches and it's not the wiring. It has to be the ACM. Where is the thing on the 2010's?
Would this be something covered under warranty?
cyclemonkey is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 09-17-2011, 07:11 AM
Lifetime Premium
 
kevinx's Avatar
 
Join Date: Dec 2009
Location: At Southern Motorworx. High Springs Fl
Posts: 2,646
Default

There is no ACM on a 10. Have you looked at ALL your fuses??

I'm not an asshole...I just type that way
Check us out at Southern Motorworx on FaceBook
https://www.facebook.com/home.php
http://www.southernmotorworx.com/index.html
kevinx is offline  
post #5 of 6 (permalink) Old 09-17-2011, 07:16 AM Thread Starter
Junior Member
 
Join Date: May 2010
Posts: 13
Default

Kevin,
I've looked at all of the 15 midget fuses for the lights and swapped the relays out just to be sure. Nothing.
cyclemonkey is offline  
post #6 of 6 (permalink) Old 09-17-2011, 12:07 PM
Senior Member
 
handyhoward's Avatar
 
Join Date: Jul 2011
Location: FL
Posts: 545
Garage
Default

Change out your bulbs... one at a time or all at once.

Handy

2013 Indian Vintage Chief FE... #7 of 25

2011 Victory Vision Tour Premium...
handyhoward is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome