Frustration!!! - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old 10-02-2011, 07:34 PM Thread Starter
Senior Member
 
Nycskool50's Avatar
 
Join Date: Aug 2011
Location: NYC
Posts: 170
Default Frustration!!!

Few weeks ago I rewired my entire bike from the ACM back. I rerouted the harness and did all the good stuff. Well, everything seemed to work fine except the right rear turn signal. Since I spent the better part of an entire weekend doing it, I decided I didn't care too much and I would live without it until I decided it was time to try again. On Friday I found me a little motorcycle repair shop in the Bx, one where they fix your bike right out there in the middle of the street. The guy came out, check a few wires and it would seem I was not getting a negative polarity from the ground wire so he grounded the signal light to the bolt that holds on the turn signals and success, right turn signal works. Now today I take the back of the bike apart to run some wire for the license plate bracket, put it back together and the right turn signal is GONE!!! I did everything he did, but still not signal. UGH...any suggestions?

2007 Hammer Premium
Nycskool50 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-02-2011, 10:24 PM
Senior Member
 
philmonger's Avatar
 
Join Date: Sep 2011
Location: Eastern MA
Posts: 427
Default

Clean the ground contact.
philmonger is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome