Newb Needs Help Please - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 20 (permalink) Old 05-31-2014, 03:57 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default Newb Needs Help Please

So today I'm cruising along the highway, my 2012 Hardball is working great! I stop for a break and start going again and My speedo is not working, or my gear indicator or my cruise? All were fine before I stopped! Please help!
Focker is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 05-31-2014, 04:21 PM
Administrator
 
CrossRoads's Avatar
 
Join Date: Sep 2010
Location: OC, CA
Posts: 5,947
Default

Quote:
Originally Posted by Focker View Post
So today I'm cruising along the highway, my 2012 Hardball is working great! I stop for a break and start going again and My speedo is not working, or my gear indicator or my cruise? All were fine before I stopped! Please help!
How are your blinkers and your horn? If they're also not working, it's a fuse. Check and replace burned fuse. If horn and blinkers do work, you have a lose connector inside the headlight. Open it up (4 screws) and find the lose connector, and make sure it clicks closed.

Please add your bike's year and model to your signature. Here's why.
------------------------------------------------------------------------------
Riding: 2011 Cross Roads & 2016 Springfield
------------------------------------------------------------------------------
---------------------------------------
Blest with victory and peace, may the heav'n rescued land
Praise the Power that hath made and preserved us a nation.
Then conquer we must, when our cause it is just,
And this be our motto: "In God is our trust."
And the star-spangled banner in triumph shall wave
O'er the land of the free and the home of the brave!
CrossRoads is offline  
post #3 of 20 (permalink) Old 05-31-2014, 04:55 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default

Quote:
Originally Posted by CrossRoads View Post
How are your blinkers and your horn? If they're also not working, it's a fuse. Check and replace burned fuse. If horn and blinkers do work, you have a lose connector inside the headlight. Open it up (4 screws) and find the lose connector, and make sure it clicks closed.
Yes, everything else seems to be working fine. I will check the connection in the headlight. Thanks
Focker is offline  
Sponsored Links
Advertisement
 
post #4 of 20 (permalink) Old 06-01-2014, 01:58 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default

Ok so I checked all the battery connections, fuses and took the headlight apart and disconnected the connection and reconnected. My speedo still won't work? The cruise power light comes on but won't set a speed? And the odometer does not work? Any other suggestions?
Focker is offline  
post #5 of 20 (permalink) Old 06-01-2014, 04:28 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,092
Default

Faulty speed sensor?

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #6 of 20 (permalink) Old 06-01-2014, 07:00 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default

Quote:
Originally Posted by RICZ View Post
Faulty speed sensor?
Quite possibly? Where exactly would that be located?
Focker is offline  
post #7 of 20 (permalink) Old 06-01-2014, 08:08 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,092
Default

I have no idea. That was a wild guess.

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #8 of 20 (permalink) Old 06-02-2014, 06:46 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default

Quote:
Originally Posted by RICZ View Post
I have no idea. That was a wild guess.
Good guess! That's exactly what it is! Ordered a new one today. Thanks
Focker is offline  
post #9 of 20 (permalink) Old 06-02-2014, 07:01 PM
Senior Member
 
RICZ's Avatar
 
Join Date: Sep 2010
Location: Portland,Oregon
Posts: 12,092
Default

That was a lucky guess on my part, I'm going to buy a lottery ticket tonight. Where is the sensor located so I'll know for future reference?

2010 Midnight Cherry XR. 7Jurock, Lloydz AF, ATS, AFR tuned VFCIII, IAV, and T-6 and locally repacked pipes = big smiles. SOLD to a dear friend, so it's still in the family."
2017 Spyder F3 Limited - keeps this old guy in the wind and riding with friends.
Cure that ugly stand up license plate with the cheapest and best laydown bracket. Click this:
https://www.victoryforums.com/11-ven...t-x-bikes.html
RICZ is offline  
post #10 of 20 (permalink) Old 06-02-2014, 07:39 PM Thread Starter
Member
 
Join Date: May 2014
Location: Alberta
Posts: 72
Default

Quote:
Originally Posted by RICZ View Post
That was a lucky guess on my part, I'm going to buy a lottery ticket tonight. Where is the sensor located so I'll know for future reference?
There's a plug on top of the transmission with one bolt. Unplug the sensor and remove the bolt and put the new one in and bolt it down and plug it in! 100 bucks
Focker is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome