Signal light circuit blew fuse now no longer working on 2009 Jackpot - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 9 (permalink) Old 02-20-2012, 02:08 PM Thread Starter
Member
 
09nessjackpot's Avatar
 
Join Date: Oct 2011
Location: Central CT
Posts: 39
Default Signal light circuit blew fuse now no longer working on 2009 Jackpot

The other day when I went to start the bike I noticed I had no neutral light, I checked the fuse box and the 15A Sec. Lights fuse was blown. I replaced it and the neutral light was working again. When I hit the signal lights, left or right it continued to blow the fuse.

After putting in a 3rd fuse the neutral light stays on, the horn which is on the same circuit works but when I activate the left, right or hazard lights I get nothing.
But everything else on that circuit works fine and no more burnt fuses!

I went as far as to remove the rear fender to check for a broken or frayed wire that could be causing a short circuit and found everything to look ok! I checked the front lights as well, all looked ok!
BTW, the head light and tail light which are on a different circuit work.

What went on the bike, a module of some sort?

I donít think itís the relay because I swapped it with another identical relay and all I get now is a click near the fuse block when I turn on or off the signal light switch or hazard light switch which is what a relay will do! HELP!!!!


2009 Cory Ness Jackpot
Dynojet PCV by Fuel Moto
S&S Performance Intake
RPW Slash pipes
Corbin seat with 2 removable backrests
Kewl Metal 45 degree rake kit
Lowering kit
Kewl Metal LED Bullet signal lights
Cycle Sounds 200 watt amp & speakers
Sony Walkman
09nessjackpot is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-20-2012, 03:27 PM
Member
 
Join Date: Dec 2011
Posts: 50
Default

have you changed/removed any parts lately? The tag light is on the same circuit and could be causing the issue if it's shorted, that's all I can really think of
wmskateteam is offline  
post #3 of 9 (permalink) Old 02-20-2012, 03:44 PM Thread Starter
Member
 
09nessjackpot's Avatar
 
Join Date: Oct 2011
Location: Central CT
Posts: 39
Default

Is the tag light known to short out for some reason?

I did have the rear fender off to fix a seat bolt insert, thought maybe I pinched a wire when I bolted the plastic piece for the rear lights back onto the fender.

I did find a little black box under the seat next to the cpu connector, that is what's clicking, it smells burt. I think I found the problem but may still have a short somewhere. Maybe after blowing the fuse 3 times that part went, not sure what it is, will have to try to find a wiring diagram!

Still need help, problems not fixed yet!


2009 Cory Ness Jackpot
Dynojet PCV by Fuel Moto
S&S Performance Intake
RPW Slash pipes
Corbin seat with 2 removable backrests
Kewl Metal 45 degree rake kit
Lowering kit
Kewl Metal LED Bullet signal lights
Cycle Sounds 200 watt amp & speakers
Sony Walkman
09nessjackpot is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 02-20-2012, 03:45 PM
Lifetime Premium
 
BBob's Avatar
 
Join Date: Aug 2010
Location: NW AZ
Posts: 12,829
Garage
Default

Sounds like maybe the ASM (Automatic Signal Module) went out. I think Noemtz has them for the best price. There's a way to bypass them so you have to manually turn off the signals but I don't know how to do that. Someone appears to have done that on my 04 Kingpin though.

It's a well know weak point in the electrical system. One of the turn signals on the front is wired backwards from the factory and if another signal isn't wired in the same way; it'll kill the ASM. You might do a search here and on other forums.
BBob is offline  
post #5 of 9 (permalink) Old 02-20-2012, 03:54 PM Thread Starter
Member
 
09nessjackpot's Avatar
 
Join Date: Oct 2011
Location: Central CT
Posts: 39
Default

Ok, I just checked Polaris online parts and the little black box I just mentioned is part #4012103 Module, Flasher, 10W

I guess I should get a couple of them, something tells me the first one will fry again if I still have a short somewhere, god I hope not!


2009 Cory Ness Jackpot
Dynojet PCV by Fuel Moto
S&S Performance Intake
RPW Slash pipes
Corbin seat with 2 removable backrests
Kewl Metal 45 degree rake kit
Lowering kit
Kewl Metal LED Bullet signal lights
Cycle Sounds 200 watt amp & speakers
Sony Walkman
09nessjackpot is offline  
post #6 of 9 (permalink) Old 02-20-2012, 03:58 PM Thread Starter
Member
 
09nessjackpot's Avatar
 
Join Date: Oct 2011
Location: Central CT
Posts: 39
Default

Quote:
Originally Posted by BBob View Post
Sounds like maybe the ASM (Automatic Signal Module) went out. I think Noemtz has them for the best price. There's a way to bypass them so you have to manually turn off the signals but I don't know how to do that. Someone appears to have done that on my 04 Kingpin though.

It's a well know weak point in the electrical system. One of the turn signals on the front is wired backwards from the factory and if another signal isn't wired in the same way; it'll kill the ASM. You might do a search here and on other forums.
Thanks Bob, that's good to know, if it is a weak point then maybe that is what actually shorted and not the wiring!

Maybe that's why someone modified or bypassed it!

Should I just search for Automatic Signal Module to see what the issues are with them?
Who is Noemtz? Are they online? If you have a web address please send it!


2009 Cory Ness Jackpot
Dynojet PCV by Fuel Moto
S&S Performance Intake
RPW Slash pipes
Corbin seat with 2 removable backrests
Kewl Metal 45 degree rake kit
Lowering kit
Kewl Metal LED Bullet signal lights
Cycle Sounds 200 watt amp & speakers
Sony Walkman

Last edited by 09nessjackpot; 02-20-2012 at 04:00 PM. Reason: ?
09nessjackpot is offline  
post #7 of 9 (permalink) Old 02-20-2012, 05:10 PM
Lifetime Premium
 
NOEMTZ's Avatar
 
Join Date: Jul 2009
Location: TEXAS
Posts: 1,567
Garage
Default

I would double and triple check to be sure all wires are sound before replacing the Flasher Module. If problem is still there...you will just fry another $60 part.

www.noemtz.com
Parts & Accessories, Grips, Pegs,Tail Lights, Clear Signal Lenses, Clutch Cable Repair Kits, Custom Tank Badges, Brake Pads, Led Conversions and installation, 12 Volt Adaptors, Chrome, Dyna Beads Wheel Balancing, Heel Blades, Kickstand extensions and much more!

"I Would Rather Die On My Feet, Than Live On My Knees...Emiliano Zapata - 1910"
ďI DONíT PICK SIDES, GO WITH THE FLOW, OR PUT UP WITH BULLSHIT.
I RELY SOLELY ON MYSELF, BEAUSE I HAVE MY OWN BACK. NOEMTZ - 2010Ē
NOEMTZ is offline  
post #8 of 9 (permalink) Old 02-20-2012, 05:28 PM Thread Starter
Member
 
09nessjackpot's Avatar
 
Join Date: Oct 2011
Location: Central CT
Posts: 39
Default

Is it only $60? I just read another post you just made and you said they are $200. Or was that a totally different module?

Can you tell me the common places to check for a short?
Do I need to check inside the headlight, it looks like the front signal lights go into the headlight!

Checking out your website right now, some really cool stuff but didn't see the module there.


2009 Cory Ness Jackpot
Dynojet PCV by Fuel Moto
S&S Performance Intake
RPW Slash pipes
Corbin seat with 2 removable backrests
Kewl Metal 45 degree rake kit
Lowering kit
Kewl Metal LED Bullet signal lights
Cycle Sounds 200 watt amp & speakers
Sony Walkman
09nessjackpot is offline  
post #9 of 9 (permalink) Old 02-21-2012, 12:10 AM
Lifetime Premium
 
NOEMTZ's Avatar
 
Join Date: Jul 2009
Location: TEXAS
Posts: 1,567
Garage
Default

Quote:
Originally Posted by 09nessjackpot View Post
Is it only $60? I just read another post you just made and you said they are $200. Or was that a totally different module?

Can you tell me the common places to check for a short?
Do I need to check inside the headlight, it looks like the front signal lights go into the headlight!

Checking out your website right now, some really cool stuff but didn't see the module there.
08 and older use the ACM Module = $200
09 and newer using Flasher Module = $60

Here is why....08 older use a two stage tail/brake light...250-500 Milliamp.....versus 09 and newer use standard 12 volt for both tail and brake functions.

Without your bike here..... for signal issues...I would start with anything you may have added aftermarket... check for pinched, grounded or unshielded wires. Then move on to tracing wires any near any part you may have removed and installed. Again... check for pinched, grounded or unshielded wire. Then check a common issue under rear fender with wires and insulation missing due to rubbing from tire or fender where harness feeds in under fender to under seat. You can trace wires anywhere on that bike with a little effort... take your time.

If fuses were blowing originally.... that means a hot wire in that circuit was going to ground by cross connection, incorrectly connecting something or just plan insulation rubbed off and bare wire making contact with metal surface. The fuse is meant to only protect the wire.... not the devices.

If you kept swapping fuses without correcting the issue.... you may have affected other components like the Flasher Module.

Take your time and be thorough.

www.noemtz.com
Parts & Accessories, Grips, Pegs,Tail Lights, Clear Signal Lenses, Clutch Cable Repair Kits, Custom Tank Badges, Brake Pads, Led Conversions and installation, 12 Volt Adaptors, Chrome, Dyna Beads Wheel Balancing, Heel Blades, Kickstand extensions and much more!

"I Would Rather Die On My Feet, Than Live On My Knees...Emiliano Zapata - 1910"
ďI DONíT PICK SIDES, GO WITH THE FLOW, OR PUT UP WITH BULLSHIT.
I RELY SOLELY ON MYSELF, BEAUSE I HAVE MY OWN BACK. NOEMTZ - 2010Ē
NOEMTZ is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome