Need help...V92C died while riding!!! - Victory Forums - Victory Motorcycle Forum
Reply
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 12 (permalink) Old 09-17-2014, 08:53 AM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default Need help...V92C died while riding!!!

I recently got my bike back on the road and was running fine... Riding last night and it just died, no warning at all other than sluggish start after running for a bit ... Nothing on now with the key on at all... Battery has juice and checked fuses... absolutely nothing now...
Any help would be greatly appreciated!!!

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 09-17-2014, 11:08 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

If it just died you need to
Check battery bolts with a 10mm wrench. No your hand is not good enough. If the battery is 3 years old it might be shot.

If battery is good and you have headlight but bike will not start your fuel pump might be shot.

Check to see if you have spark.

Tell us more how it will not start does it turn over.

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #3 of 12 (permalink) Old 09-17-2014, 12:15 PM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default

Battery terminals good... Battery is fairly new... No head light response no electrical on at all totally dead when turned on nothing at all...Checked fuses nothing burnt... Everything seems good... Always check my headlight to see charging and it was good...
Thank you...

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 09-17-2014, 01:24 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

look inside headlight for bad wire. check ground wire going to motor with a wrench.

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #5 of 12 (permalink) Old 09-17-2014, 01:30 PM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default

Ok will do thank you...

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
post #6 of 12 (permalink) Old 09-17-2014, 06:17 PM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

Maybe your ignition switch failed

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #7 of 12 (permalink) Old 09-18-2014, 04:41 AM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default

I went back through the bike and this time checked the fuses with a test light, the ignition fuse was blown... Now every time I put a new fuse in it blows it...

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
post #8 of 12 (permalink) Old 09-18-2014, 11:50 AM
Senior Member
 
visionjohnny's Avatar
 
Join Date: Sep 2010
Location: minnesota
Posts: 12,946
Default

start tracing wire for the bad spot. Look under seat for pinched wire even under gas tank

2008 Vision
Mpls, MN.

Please add your state and model of bike you have. Click user CP @ top of page and then far left click edit signature. Thanks
visionjohnny is offline  
post #9 of 12 (permalink) Old 09-18-2014, 08:44 PM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default

I think your right... Its got to be the ignition...

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
post #10 of 12 (permalink) Old 09-20-2014, 11:39 AM Thread Starter
Junior Member
 
Carl T's Avatar
 
Join Date: Jan 2010
Location: Ft. Worth TX.
Posts: 25
Default

Like the fuel pump n oil filter is there an ignition that you can pick up from a regular part store???

2000 V92C
Custom Paint by Me...
www.helmetpaint.com
Carl T is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome