2000 V92c Wire Harness - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 04-09-2015, 11:04 AM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 6
Default 2000 V92c Wire Harness

Hello all,
Re: 2000 V92c Wire Harness

I just ran into an issue where my tail light shorted out and blew a fuse...
I went to take the bike for a ride and it was completely dead...
I checked the battery voltage and was reading 12 volts so I figured it was likely a fuse.
I checked the fuses 1 by 1 until I came upon the fuse "FLASHER 10A IGNITION"
I replaced the fuse and was happy as a clam when I turned the ignition key and was able to start up...
About 30 seconds later heave smoke came from the fuse block and the wire harness started burning up...
I quickly shut down and doused the flames with water.
Looks like my wire harness and fuse block is roached...

Does anyone have any idea what this would cost to replace?
I'd hate to have to loose the bike over some wires and a few components...

What does a typical Victory shop charge for something like this?

What other components if any are likely to need replacement?



PS: I likely posted this thread in another victory forum area... my apologies
1st Victory is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-09-2015, 12:28 PM
Senior Member
 
Ghost_Rider's Avatar
 
Join Date: Aug 2012
Location: Culpeper, VA
Posts: 681
Garage
Default

Try Pinwall cycle or sun coast cycle sports on eBay. They'll probably have something

2003 V92C
Wrapped RPW Slash pipes
K&N air filter
Stebel Nautilus
Viking saddlebags
16" apes
Ghost_Rider is offline  
post #3 of 4 (permalink) Old 05-03-2015, 09:43 AM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 6
Default Found Harness

Thanks for the info about Pin Wall Cycles...

They had what I needed with regards to a wiring harness...

There seems to be some connector plugs that are un-used?
They just don't have anything to plug into, possible this harness us used on other models?

Everything is working except my starter doesn't turn, the relay clicks and is sounds like the fuel pump cycles for a second or two...
I'm fairly certain everything is connected correctly...
The harness has a few permanent bends that make the connector plugs quite obvious as to where they belong with the exception of a few that don't go anywhere...
1st Victory is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 05-03-2015, 09:02 PM
Senior Member
 
Ghost_Rider's Avatar
 
Join Date: Aug 2012
Location: Culpeper, VA
Posts: 681
Garage
Default

Some of them may not go anywhere. Try bumping the starter with a hammer while pushing the start button

2003 V92C
Wrapped RPW Slash pipes
K&N air filter
Stebel Nautilus
Viking saddlebags
16" apes
Ghost_Rider is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome