04 TC Speedo - TS indicator not working - Victory Forums - Victory Motorcycle Forum
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 2 (permalink) Old 10-04-2012, 06:34 AM Thread Starter
Senior Member
 
Tims_04V92TC's Avatar
 
Join Date: Oct 2011
Location: Chesapeake Va
Posts: 1,499
Garage
Default 04 TC Speedo - TS indicator not working

Ok this has got me. My RT turn signal indicator in the speedo quit on me. No big deal, the ACM works fine and if in doubt stab the switch. Well that is fine until inspection time. Now I was just about to roll it up there and I thought "I think this is required".... duh... well I am about to swing by and double check but my headache lies in finding the darn bulb.

Pulled the speedo, removed the rear access cover thinking I would find bulb holes in the circuit card but to my surprise no. Well, I will open my trusty service manual since this seems to be difficult.. Nothing... WTH??? Next stop, trust the forums. Who has had to change this before and am I safe disconnecting the speedo's electronics connector without unhooking the battery? Any help appreciated and if I am not providing enough info let me know. Thanks!

2011 White Vision - Nuvi 550, Lowers, Lloydz 2nd filter, Vic perf filter, CB/Icom, 96 Brake LED's, Clear Signal lens/Switchbacks, VIC Hwy Pegs, Stebel Horn, 7Jurock 15" Shield, PCV, Lloyd ATS and Variable intake, Ness honkers

2004 V92 TC - S1 flash, level 1 slip-on, Ness big sucker K&N, ISO Grips, 4x1.5 Highway Hawg Risers, extra chrome (never too much), JM 2k CB 4' antena, Mustang seat, HD Front TS & Lowers, OD Pulley

IBA Rider
Retired Navy SCPO
Chesapeake Va
Tims_04V92TC is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 10-07-2012, 08:15 AM Thread Starter
Senior Member
 
Tims_04V92TC's Avatar
 
Join Date: Oct 2011
Location: Chesapeake Va
Posts: 1,499
Garage
Default

**Bump**

Just checking. Anyone have any experience opening up an 04 TC speed odometer to replace the turn signal indicator? Only thing I could find was a face replacement but did not want to open the face that way unless I am sure there are bulbs behind it. Anyone know if indicator is a board LED or something. Any help appreciated. About to take it to the shop. Sigh....

2011 White Vision - Nuvi 550, Lowers, Lloydz 2nd filter, Vic perf filter, CB/Icom, 96 Brake LED's, Clear Signal lens/Switchbacks, VIC Hwy Pegs, Stebel Horn, 7Jurock 15" Shield, PCV, Lloyd ATS and Variable intake, Ness honkers

2004 V92 TC - S1 flash, level 1 slip-on, Ness big sucker K&N, ISO Grips, 4x1.5 Highway Hawg Risers, extra chrome (never too much), JM 2k CB 4' antena, Mustang seat, HD Front TS & Lowers, OD Pulley

IBA Rider
Retired Navy SCPO
Chesapeake Va
Tims_04V92TC is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome