Waste of 1yr and my insurance money - Victory Forums - Victory Motorcycle Forum
 1Likes
  • 1 Post By vicwick
 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 10-11-2015, 06:43 PM Thread Starter
Member
 
Savorino's Avatar
 
Join Date: Apr 2014
Location: S.E. Michigan
Posts: 35
Default Waste of 1yr and my insurance money

Started out late last year with a speedometer/check engine light problem, 1yr and now worse than before. Couldn't even get out of the driveway before the check engine light came on, no turn signals work. Took another look and replaced speed sensor again and now won't even start........arg.

I've made it worse than before and wish I'd have taken it in, way wah.

'03 V92C Stage-I
Savorino is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-11-2015, 07:04 PM
Senior Member
 
rojo154's Avatar
 
Join Date: Aug 2010
Location: Southington, Conn.
Posts: 195
Garage
Default

You didn't mention what steps you have taken .. Back to basics, Clean and tight battery cables (this will cause check engine light to come on) low battery voltage. May be time to take in to a shop.

2011 Kingpin
custom paint
Ness fly bars
xbow exhaust
S&S air intake
Dobeck fuel controller
chrome floorboards
cruise control

2004 Kingpin
Victory performance exhaust
customized air box / K+N filter
LLoydz fuel controller
custom oil lines
custom led lighting
custom led third brake lights
Sold ..( my baby, still have some sellers remorse)


2011 XC
rpw exhaust
wiseco fuel controller
Sold
rojo154 is offline  
post #3 of 4 (permalink) Old 10-11-2015, 08:30 PM Thread Starter
Member
 
Savorino's Avatar
 
Join Date: Apr 2014
Location: S.E. Michigan
Posts: 35
Default

I just came from the garage and needed to wah wah a bit. I am no longer looking for help here. If it was going to happen, it would have happened by now. My previous posts are available if you are curious.
Thank's roso154 for your interest though.

'03 V92C Stage-I
Savorino is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 10-11-2015, 09:02 PM
Junior Member
 
vicwick's Avatar
 
Join Date: Sep 2015
Location: Sparks Nevada
Posts: 14
Default

Glad you got the wah wah out of your system. Use the vast store of knowledge on this and other forums to parse the problem into a manageable size and make riding enjoyable again.
tigerdna likes this.
vicwick is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Victory Forums - Victory Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome